Bug 89127 - RFE: IDTXglob/IDTXload methods need changes
Summary: RFE: IDTXglob/IDTXload methods need changes
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: rpm-python   
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-17 21:43 UTC by Adrian Likins
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-15 04:14:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test script for showing memory leak (345 bytes, text/plain)
2003-04-17 21:44 UTC, Adrian Likins
no flags Details

Description Adrian Likins 2003-04-17 21:43:15 UTC
Description of problem:

looks like results of IDXTLoad() never get
garbage collected... test script included
that shows it... just run that and it will
eat about 25 megs every iteration...

Version-Release number of selected component (if applicable):
[root@sludge test]# rpm -q rpm
rpm-4.2-0.67


How reproducible:
pretty easy, see script...

Steps to Reproduce:
1. run test script...

Comment 1 Adrian Likins 2003-04-17 21:44:36 UTC
Created attachment 91183 [details]
test script for showing memory leak

Comment 2 Jeff Johnson 2003-04-18 15:16:26 UTC
Heh, missed refcount on header while building tuple of tuples of headers.
IDTXglob too.

What's bogus (by design) is sucking every header out of a rpmdb into
a >40Mb data structure. Getting an iterator on top of the glop, or
adding cutoff time on retrieval, is gonna be needed.

Changinging bug to RFE ...

Comment 3 Jeff Johnson 2003-06-25 16:57:33 UTC
refcount bug fixed, converting to RFE for iterator.

Comment 4 Jeff Johnson 2003-09-15 04:14:54 UTC
Moot problem afaik.


Note You need to log in before you can comment on or make changes to this bug.