Bug 89135 - RPM seg faults after upgrade to glibc-2.3.2
RPM seg faults after upgrade to glibc-2.3.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 23:27 EDT by Rick Knight
Modified: 2016-11-24 09:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-23 19:07:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Knight 2003-04-17 23:27:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
After upgrading to Glibc-2.3.2 rpm will no longer install, erase or upgrade
packages. When rpm is run with -Uvh, -ivh, -e the "preparing" message appears
along with the hash marks, but when it reaches 100% it gives a sementation
fault. Other rpm functions do work and /usr/lib/rpm/rpmi works.

Version-Release number of selected component (if applicable):
2.3.2-11.9

How reproducible:
Always

Steps to Reproduce:
1.run -Uvh rpmfile.rpm
2.
3.
    

Actual Results:  Segmentation fault

Expected Results:  Application should have installed

Additional info:
Comment 1 Jakub Jelinek 2003-04-23 19:07:52 EDT
I don't remember releasing glibc-2.3.2 for RHL7.3.
Certainly, if you upgrade glibc and want to use NPTL, you need to upgrade rpm
too (and lots of other stuff, since several programs were not #including <errno.h>
before using errno), because rpm is statically linked and having it dlopen
NPTL libraries when the statically linked binary doesn't know anything about TLS
cannot work very well.
As rpm doesn't work for you ATM, do mv /lib/tls /lib/notls; then upgrade rpm,
then mv /lib/notls /lib/tls followed by ldconfig. And upgrade to 27.9, 11.9
had some important issues.
Comment 2 Manu Garg 2004-02-03 17:46:22 EST
Hi Jakub,

May be I am too naive, I am having similar problem and I dont see 
any /lib/tls on my machine (I am using Red Hat 8). Please suggest me 
some solution as I am badly stuck by it.

Manu Garg,
Tata Consultancy Services.
Comment 3 Robert Henryk Zawiasa 2004-02-29 05:47:01 EST
$ ls -l *.rpm
-rw-rw-r--    1 root     root       134717 May 13  2003
popt-1.7.1-1.8x.i386.rpm
-rw-rw-r--    1 root     root      6054516 May 13  2003
rpm-4.1.1-1.8x.i386.rpm
-rw-rw-r--    1 root     root       219118 May 13  2003
rpm-build-4.1.1-1.8x.i386.rpm
-rw-rw-r--    1 root     root     13264779 May 13  2003
rpm-devel-4.1.1-1.8x.i386.rpm
-rw-rw-r--    1 root     root       439192 May 13  2003
rpm-python-4.1.1-1.8x.i386.rpm
$ rpm2cpio rpm-4.1.1-1.8x.i386.rpm | cpio -idmv bin/rpm
$ bin/rpm -Uvh *.rpm

       :)

Note You need to log in before you can comment on or make changes to this bug.