Bug 891391 - [hi] deprecated modules should not be translated from msgid to msgstr
Summary: [hi] deprecated modules should not be translated from msgid to msgstr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: 771481
TreeView+ depends on / blocked
 
Reported: 2013-01-02 19:32 UTC by John Sefler
Modified: 2014-02-04 18:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 09:06:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0350 0 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-02-20 20:53:35 UTC

Description John Sefler 2013-01-02 19:32:00 UTC
Description of problem:
When a word is actually referring to a command line module, it should not be translated.

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep -i -A1 -- "deprecated, see"
msgid "Deprecated, see --auto-attach"
msgstr "पदावनत, --auto-attach देखें"
--
msgid "Deprecated, see attach"
msgstr "पदावनत संलग्नक देखें"
--
msgid "Deprecated, see remove"
msgstr "पदावनत, हटाना देखें"
--
msgid "deprecated, see auto-attach-interval"
msgstr "पदावनत, see auto-attach-interval देखें"


Actual results:
above

Expected results:
"attach" and "remove" should not be translated

Additional info:

Comment 2 Rajesh Ranjan 2013-01-03 13:22:17 UTC
Updated the strings as per the instructions. Please check if all are fine now.

Comment 3 Adrian Likins 2013-01-04 18:12:24 UTC
fixed upstream, should be in 1.1.19

Comment 5 John Sefler 2013-01-08 20:06:52 UTC
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep -i -A1 -- "deprecated, see"
msgid "Deprecated, see --auto-attach"
msgstr "पदावनत, --auto-attach देखें"
--
msgid "Deprecated, see attach"
msgstr "पदावनत, attach देखें"
--
msgid "Deprecated, see remove"
msgstr "पदावनत, remove देखें"
--
msgid "deprecated, see auto-attach-interval"
msgstr "पदावनत, auto-attach-interval देखें"


VERIFIED

Comment 7 errata-xmlrpc 2013-02-21 09:06:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html


Note You need to log in before you can comment on or make changes to this bug.