Bug 8914 - rc.sysinit complains on ] error
Summary: rc.sysinit complains on ] error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-27 08:32 UTC by Daniel Stenberg
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-27 23:33:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Stenberg 2000-01-27 08:32:08 UTC
The following piece of the /etc/rc.d/rc.sysinit script does not work
satisfactory when the directories in question are empty:

# Clean up /var
# I'd use find, but /usr may not be mounted.
for afile in /var/lock/* /var/run/*; do
   if [ -d $afile ]; then
      rm -f $afile/*
   else
      rm -f $afile
   fi
done

The if-condition should instead be written

   if [ -d "$afile" ]; then

The warning that is displayed is perfectly harmless but still annoying
since the user can't really know that it is this harmless...! ;-)
q

Comment 1 Bill Nottingham 2000-01-27 23:33:59 UTC
Will be fixed in initscripts-4.85 when it's released.


Note You need to log in before you can comment on or make changes to this bug.