Bug 89154 - LTC2034-apache maxed at 256 connections
LTC2034-apache maxed at 256 connections
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-18 12:17 EDT by IBM Bug Proxy
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-16 15:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-04-18 12:17:29 EDT
Please fill in each of the sections below.

Hardware Environment: iSeries

Software Environment: 7.1 refresh (64bit kernel)


Steps to Reproduce:
1.  start lots of http connections
2.
3.

Actual Results:

Expected Results:

Additional Information:
Apache on 7.1 redhat is built to max out at 256 connections.  It'd be nice it
was higher - like 2048 (or more?).  On iSeries, the workload estimators can't
even run enough to get an idea of the performance of the system because of this
limitation.
Comment 1 Guy Streeter 2003-06-13 15:48:34 EDT
fixed for 7.1 pSeries and iSeries in apache-1.3.27-1.7.1.1p
Comment 2 Guy Streeter 2003-06-16 15:39:17 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2003-202.html
Comment 3 Mike Ranweiler 2003-06-23 17:57:19 EDT
------- Additional Comment #12 From Michael Ranweiler  2003-06-23 17:41 -------

The binary is fixed, but the httpd.conf file is still set with MaxClients 150 -
I believe this needs to be set to 2048 to take advantage of the
HARD_SERVER_LIMIT in httpd.h.  I think this is pretty much adequately addressed
in the errata notice:

Description:
An enhanced version of the Apache HTTP server is available for iSeries and
pSeries systems. This release increases the maximum value of the MaxClients
configuration parameter to 2048. This value represents the maximum number
of child processes the httpd daemon will start.

Closing this bug as verified.

Note You need to log in before you can comment on or make changes to this bug.