Bug 891548 - mediacheck can't be skipped, drops to emergency shell
mediacheck can't be skipped, drops to emergency shell
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-03 03:54 EST by Kamil Páral
Modified: 2013-05-29 21:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 21:32:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-01-03 03:54:22 EST
Description of problem:
This is a fork of bug 874486. Mediacheck progress is now displayed, but hitting Esc drops user to an emergency shell, rather then skipping the check and continuing to load the installer.

Please read bug 874486 comment 45 and onward. See attachment 667096 [details].

Version-Release number of selected component (if applicable):
anaconda-18.37.8-1.fc18

How reproducible:
always

Steps to Reproduce:
1. hit Esc during mediacheck
  
Actual results:
emergency shell

Expected results:
installer continues to load
Comment 1 Andre Robatino 2013-01-03 04:39:56 EST
Does fixing this require changing the exit values of checkisomd5? The man page currently says

EXIT STATUS
       Program  returns exit status 0 if the checksum is correct, or 1 if the
       checksum is incorrect, non-existent, or check was aborted.

so it can't distinguish between FAIL and UNKNOWN since both return 1. I think it would be good in the long run to have 3 return values, but this would affect existing code and I don't know how much work that involves.
Comment 2 Andre Robatino 2013-02-04 15:00:49 EST
Filed bug 907600 against isomd5sum, requesting an additional return value for UNKNOWN (so the installer can continue on either PASS or UNKNOWN, and drop to an emergency shell on FAIL).
Comment 3 Andre Robatino 2013-03-23 17:09:36 EDT
This appears fixed in 19 Alpha TC1. Hitting Esc lets the install continue.
Comment 4 Adam Williamson 2013-05-12 19:34:09 EDT
In 19 Beta TC4, this is not fixed. Pressing Esc just toggles plymouth's progress bar - hit Esc, you see the progress bar, hit Esc again, you see the media check percentage.

You can't completely break it any more, but neither can you skip the check.
Comment 5 Brian Lane 2013-05-14 12:33:35 EDT
commit c9a6cebabf for bug 958924 fixes this on my smoke-test boot.iso
Comment 6 Adam Williamson 2013-05-29 21:32:42 EDT
Yup, it's been working since then.

Note You need to log in before you can comment on or make changes to this bug.