Bug 891556 - error: attempt to use poisoned "SIG_USART0_RECV" on arduino mega 2560
error: attempt to use poisoned "SIG_USART0_RECV" on arduino mega 2560
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: arduino (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: T.C. Hollingsworth
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 905681
  Show dependency treegraph
 
Reported: 2013-01-03 04:15 EST by andrew2.hart
Modified: 2013-02-13 21:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 21:22:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix the problem (352 bytes, patch)
2013-01-22 05:02 EST, T.C. Hollingsworth
no flags Details | Diff

  None (edit)
Description andrew2.hart 2013-01-03 04:15:13 EST
Description of problem:
Verifying/Compiling for arduino mega 2560 fails.

Version-Release number of selected component (if applicable):
1.0.1-1.fc18

How reproducible:
Everytime

Steps to Reproduce:
1.run arduino, select Tools->Board->Arduino mega 2560..
2.Select Sketch->Verify/Compile
3.Error produced
  
Actual results:
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:91:41: error: attempt to use poisoned "SIG_USART0_RECV"

Expected results:
Should warn about undefined setup and loop functions.

Additional info:
Comment 1 T.C. Hollingsworth 2013-01-22 05:02:15 EST
Created attachment 684969 [details]
patch to fix the problem

This has been fixed in the updated version of the Arduino IDE.

I understand from bug 875397 there might a bundled library issue holding up the new version?  If so the attached patch to the arduino source will fix builds with the current version in Fedora.
Comment 2 T.C. Hollingsworth 2013-01-31 22:03:52 EST
Ping?

I requested ACLs in pkgdb in case you'd rather I just fix it myself.  I don't mind.  ;-)
Comment 3 andrew2.hart 2013-02-01 03:29:55 EST
The patch that you supplied works for me.  Thanks.
Comment 4 Peter Oliver 2013-02-01 17:28:36 EST
(In reply to comment #2)

> I requested ACLs in pkgdb in case you'd rather I just fix it myself.  I
> don't mind.  ;-)

Thanks, please go ahead.  Apologies for not getting to this sooner.
Comment 5 Fedora Update System 2013-02-01 18:27:40 EST
arduino-1.0.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/arduino-1.0.1-2.fc17
Comment 6 Fedora Update System 2013-02-01 18:29:15 EST
arduino-1.0.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/arduino-1.0.1-2.fc18
Comment 7 Fedora Update System 2013-02-03 08:41:38 EST
Package arduino-1.0.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing arduino-1.0.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1886/arduino-1.0.1-2.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-02-13 21:22:54 EST
arduino-1.0.1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-02-13 21:45:49 EST
arduino-1.0.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.