Bug 891576 - "Reclaim space" somewhat bogus when custom partitioning has been selected
"Reclaim space" somewhat bogus when custom partitioning has been selected
Status: CLOSED DUPLICATE of bug 903501
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-03 05:26 EST by Markus Armbruster
Modified: 2013-02-02 04:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-31 14:39:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2013-01-03 05:26:55 EST
Description of problem:
The button to start custom partitioning is labelled "Reclaim space".  That's not what it does.  Mildly confusing.

Version-Release number of selected component (if applicable):
Fedora-18-Beta-x86_64-Live-XFCE.iso

How reproducible:
Always

Steps to Reproduce:
1. Select Partition scheme "Standard Partition" (for bug report completeness; I don't think it matters)
2. Check the box labelled "I don't need help; let me customize disk partitioning"

Actual results:
The only active button is labelled "Reclaim space"

Expected results:
Pressing the button isn't going to reclaim anything.  It'll let me partition the disk, which may or may not involve me reclaiming disk space.  Therefore, I'd expect the button to be labelled differently.
Comment 1 Chris Lumens 2013-01-03 09:31:32 EST
We can't change this for F18, but we can change it for rawhide.
Comment 2 Máirín Duffy 2013-01-30 15:54:14 EST
Markus, this is a great point - we're going to redesign the screen to fix this. We had a discussion about it in IRC today, and our intern Stephanie is going to be working on mockups for the fix this afternoon. She will post them to the bug probably tomorrow. I'd like to get your feedback on the mockups then.
Comment 3 Adam Williamson 2013-01-31 14:30:17 EST
We may want to consider this a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=903501 . If not, at least, see the discussion there, as Major Changes to this dialog are being planned in that bug.
Comment 4 Chris Lumens 2013-01-31 14:39:16 EST

*** This bug has been marked as a duplicate of bug 903501 ***
Comment 5 Markus Armbruster 2013-02-02 04:14:43 EST
Máirín, I'd like to thank you for comment#2.  It's to the point, and it radiates zeal.  Bug care like this makes bug reporters come back for more.  Exemplary!

I had a look at the latest mockups on bug 903501, and they're a clear improvement.

Note You need to log in before you can comment on or make changes to this bug.