Bug 89166 - first boot fails if OS is installed to a cciss controller that is not c0
Summary: first boot fails if OS is installed to a cciss controller that is not c0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mkinitrd
Version: 2.1
Hardware: ia64
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-18 21:37 UTC by Mike Miller (OS Dev)
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-27 13:35:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:170 normal SHIPPED_LIVE Updated mkinitrd improves support for cciss devices 2003-05-27 04:00:00 UTC

Description Mike Miller (OS Dev) 2003-04-18 21:37:45 UTC
Description of problem:
If the OS is installed to a cciss controller that is not the first cciss 
controller discovered the reboot will fail with:
  mount: error 6 mounting ext3
  pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
  umount /initrd/proc failed: 2
  Freeing unused kernel memory: 464kB freed
  Kernel panic: No init found.  Try passing init= option to kernel.

Version-Release number of selected component (if applicable):
2.4.18-e.27

How reproducible:
Evey time

Steps to Reproduce:
1. Set up a system with >1 smart array controller
2. Install the OS to something other than c0
3. Reboot the system after install completes
    
Actual results:
Kernel panic

Expected results:
Normal boot with no failures or errors

Additional info:

Comment 1 Mike Miller (OS Dev) 2003-04-18 21:41:16 UTC
A work around is to boot the system using "root=6902" if root is 
on /dev/cciss/c1d0p2. The linuxrc file in the initrd can also be modified. 
However the pivotroot message still occurs, but the system completes boot.

Comment 2 Jeremy Katz 2003-04-23 02:31:48 UTC
Since I don't have hardware configured like that here, can you try the new
mkinitrd at http://people.redhat.com/~katzj/mkinitrd/.ia64/ to see if that fixes
the problem?

Comment 3 Bill Peck 2003-05-27 13:35:36 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-170.html



Note You need to log in before you can comment on or make changes to this bug.