Bug 891668 - [abrt]: kernel BUG at fs/nfs/idmap.c:513!
[abrt]: kernel BUG at fs/nfs/idmap.c:513!
Status: CLOSED DUPLICATE of bug 891665
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:2dd76ce392395f65a7956eb3d37...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-03 10:29 EST by Emmett Culley
Modified: 2013-01-03 11:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-03 11:02:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Emmett Culley 2013-01-03 10:29:50 EST
Description of problem:
This time I tried to start nfs-idmap.service using systemctl.

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.10-2.fc17.x86_64 root=/dev/mapper/ws1-root1 ro rd.dm=0 KEYTABLE=us rd.md.uuid=deb156f4:8aa83e33:b7a035a5:013af600 SYSFONT=True rd.md.uuid=6a071f64:5ff8ee4c:006a908e:2d3c2772 rd.luks=0 rd.lvm.lv=ws1/root1 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.6.10-2.fc17.x86_64

backtrace:
:kernel BUG at fs/nfs/idmap.c:513!
:invalid opcode: 0000 [#1] SMP 
:Modules linked in: binfmt_misc ip6table_filter ip6_tables ebtable_nat ebtables nfsv3 nfs_acl nfsv4 auth_rpcgss nfs dns_resolver fscache ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xt_CHECKSUM iptable_mangle lockd sunrpc bridge stp llc snd_hda_codec_realtek uvcvideo snd_hda_intel snd_hda_codec usblp videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media snd_seq tg3 snd_usb_audio snd_usbmidi_lib snd_hwdep snd_rawmidi snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore nv_tco i2c_nforce2 edac_core k8temp edac_mce_amd vhost_net tun macvtap macvlan kvm_amd kvm raid1 firewire_ohci ata_generic pata_acpi sata_sil24 firewire_core crc_itu_t sata_nv usb_storage nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
:CPU 1 
:Pid: 2559, comm: mount Not tainted 3.6.10-2.fc17.x86_64 #1 ASUSTek Computer INC. KFN5-D SLI/KFN5-D SLI
:RIP: 0010:[<ffffffffa052a3e2>]  [<ffffffffa052a3e2>] rpc_pipefs_event+0x282/0x290 [nfsv4]
:RSP: 0018:ffff8801179a9c08  EFLAGS: 00010246
:RAX: ffff8802277baa00 RBX: ffff8801232acd38 RCX: ffff88021e42b000
:RDX: 0000000000000039 RSI: 0000000000000000 RDI: 0000000000000000
:RBP: ffff8801179a9c58 R08: 0000000000000000 R09: ffffffffa053bda0
:R10: ffff88012b807e08 R11: ffffffffffffffe8 R12: 0000000000000000
:R13: ffff8801232accc0 R14: ffff8801232accf8 R15: ffff88021e57c800
:FS:  00007fe46f72f840(0000) GS:ffff88012bc80000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 00007fe46f31c3b0 CR3: 000000012318d000 CR4: 00000000000007e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process mount (pid: 2559, threadinfo ffff8801179a8000, task ffff88012a290000)
:Stack:
: ffff8801179a9c58 ffffffffa04149db ffff88021e42b000 0000000000000000
: 0000000000000000 00000000fffffffe 0000000000000000 0000000000000000
: ffff88021e42b000 0000000000000000 ffff8801179a9c98 ffffffff81622ebd
:Call Trace:
: [<ffffffffa04149db>] ? rpc_pipefs_event+0x6b/0x2a0 [sunrpc]
: [<ffffffff81622ebd>] notifier_call_chain+0x4d/0x70
: [<ffffffff81086538>] __blocking_notifier_call_chain+0x58/0x80
Comment 1 Emmett Culley 2013-01-03 10:36:27 EST
This is almost certainly a duplicate of bug 891665 reported to nfs-maint.  Here is more explanation from that previos bug report.

"After adding nsf4 export strings to /etc/exports for the first time (nfs hasn't run on this machine since upgrading from Fedora 16), then running service nfs start, the system crashed.  Don't know if is was because I used service instead of syscemctl."
Comment 2 Josh Boyer 2013-01-03 11:02:45 EST

*** This bug has been marked as a duplicate of bug 891665 ***

Note You need to log in before you can comment on or make changes to this bug.