Bug 89171 - Old bugs in initscripts & net-tools & fry a nic, reboot -> rotates nic names and ip's -> may open lan or dmz
Old bugs in initscripts & net-tools & fry a nic, reboot -> rotates nic names ...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
All Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-18 23:44 EDT by Need Real Name
Modified: 2014-03-16 22:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-02 22:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-04-18 23:44:43 EDT
Description of problem:
..with HWADDR set, some or all nic's die, the remainder _may_ rotate.

..without HWADDR set, nic names and ip's _does_ rotate, this _MAY_ 
potentially may open a lan or dmz, because the mac addressing is 
"ignored".

..references: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75570 ,
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75572 and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=53119 ,
Additional Comment #10 From Peter H. Jones on 2001-09-07 07:49 


..and: $ head -n 166 /sbin/ifup | tail -n 13 says:
}
if [ -n "${HWADDR}" ]; then
    FOUNDMACADDR=`LC_ALL= LANG= ip -o link show ${REALDEVICE} | \
        sed 's/.*link\/ether \([[:alnum:]:]*\).*/\1/'`
    if [ "${FOUNDMACADDR}" != "${HWADDR}" ]; then
        /sbin/nameif "${REALDEVICE}" "${HWADDR}" || {
           echo $"Device ${DEVICE} has different MAC address than expected,
ignoring."
           exit 1
        }
    fi
fi

# is the device wireless? If so, configure wireless device specifics



from: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75570 :

> initscripts-6.95-1

..same bug set in initscripts-7.14-1 and net-tools-1.60-12 for RH9, AFAICT.



Version-Release number of selected component (if applicable):


How reproducible:
..my scenario is _not_ reproducible for boxes with just one nic. ;-)

Steps to Reproduce:
> 1. Configure a network interface with redhat-config-network
> 2. Select the "Bind to MAC address" option in the Hardware Device 
>    tab of the configuration dialog.
> 3. Save the network configuration
> 4. Insert a different network card (with a different MAC address)

.._different_ nic ID's can worked around with entries in 
/etc/modules.conf ,   but same type nics use the same driver, 
and _needs_some_other_ID_.

..5. So we set the HWADDR just like we did in step 2.

..6. Iterate as you see fit, using the _same_ type of nics, 
     and the same driver.

..7. Fry, or remove a nic.

..8. Restart the networking, reboot etc, etc.

    
Actual results:
..with HWADDR set, some or all nic's die, the remainder _may_ rotate.

..without HWADDR set, nic names and ip's _does_ rotate (in most 
cases), this _MAY_ potentially "turn the rear end out and lean 
over for the first scriptkiddie out there ready to romp it", 
because the mac addressing is "ignored".  

Expected results:
..dead nic's should remain dead, which is ok, _BUT_ ok nic's 
_should_ come back up with their _correct_ names and ip's and 
mac addresses.

..alternatively, I should have been able to find _something_ 
useable, STFW for a RTFM pointer in the last 3 days.

Additional info:
..these old known bugs in initscripts and net-tools for RH8 and RH9, possibly
RH-7.3 too, has been handled poorly, except for "the newbies at home" users,
where a "normal" classfication is beyond what I would do, both ways, I guess
this is because these old known bugs, are known as trivial in effect, complex to
fix, and bad effects are seen as subtle, if seen at all. 

..from: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75570 :

> initscripts-6.95-1

..same bug in initscripts-7.14-1 for RH9.

> How reproducible:
> Always

..my scenario is _not_ reproducible for boxes with just one nic. ;-)

> Steps to Reproduce:
> 1. Configure a network interface with redhat-config-network
> 2. Select the "Bind to MAC address" option in the Hardware Device 
>    tab of the configuration dialog.
> 3. Save the network configuration
> 4. Insert a different network card (with a different MAC address)

.._different_ nic ID's can worked around with entries in 
/etc/modules.conf ,  but same type nics use the same driver, 
and _needs_some_other_ID_.

..the HWADDR idea is _good_.  On installing, and with local access to the box,
in homes etc, this is just a trivial annoyance, and hardly worth fixing, most
people are used to re-installing wintendo anyway, on having a box puke on its
new nic.  "Works for me too.", BTDT etc.

..the above scenario does not warrant a "normal" classification, 
just a mention in the docs.

.._however_, this _same_ bug set, in a remote firewall, in some company, with
mission critical server stuff etc, then get a nic toasted, and then restart the
net or reboot the box, either by a power cut-off or admin commanded, _may_
rotate nic ip's and names, _because_ the mac address is "ignored".

.._this_ scenario warrants _fat_ law suits, and, under Chinese Law, neck shots,
and is _not_ acceptable for me, and I would think a fix is both cheaper and
better, than a mention in the Wintendo press of someone who finds this out the
hard way.

..same bug set in initscripts-7.14-1 and net-tools-1.60-12 for RH9, I upgraded
from RH-7.3 and RH-8.0 because I believed you _had_ fixed this.
Comment 1 Need Real Name 2003-04-18 23:58:39 EDT
..missed this:
"How reproducible:
Sometimes, but not allways.".

..my scenario is _not_ reproducible for boxes with just one nic. ;-)

Comment 2 Need Real Name 2003-04-19 00:00:41 EDT
..missed this:
"How reproducible:
Sometimes, but not allways.".

..my scenario is _not_ reproducible for boxes with just one nic. ;-)
Comment 3 Bill Nottingham 2003-04-21 11:54:16 EDT
This is a duplicate of various other bugs. We're looking at the issues involved.
Comment 4 Bill Nottingham 2003-07-02 22:58:44 EDT
In initscripts-7.26-1, interfaces which have HWADDR set will be renamed to
whatever their DEVICE= line says.

Note You need to log in before you can comment on or make changes to this bug.