Bug 891746 - Typo in rhn-channel man page
Summary: Typo in rhn-channel man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomas Lestach
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-03 21:01 UTC by Thom Carlin
Modified: 2013-11-21 23:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 23:15:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1702 normal SHIPPED_LIVE rhn-client-tools bug fix update 2013-11-20 21:52:04 UTC

Description Thom Carlin 2013-01-03 21:01:58 UTC
Description of problem:

rhn-channel references "--username" while "rhn-channel --help" actually uses "--user"

Version-Release number of selected component (if applicable):

rhn-setup-1.0.0-87.el6.noarch

How reproducible:

Every time

Steps to Reproduce:
1. man rhn-channel
2. 
3. 
  
Actual results:

PACEWALK-CHANNEL(8)             Red Hat, Inc.            SPACEWALK-CHANNEL(8)

NAME
       spacewalk-channel - Subscribe to or unsubscribe system from channel.

SYNOPSIS
       spacewalk-channel [options]

DESCRIPTION
       spacewalk-channel  allows  you  to subscribe to and unsubscribe from specified channels via the command line. A visit to the
       Red Hat Network (or Spacewalk) website isn’t required.

OPTIONS
       -l, --list
              Print a list of channel(s) that you are currently subscribed to.

       -L, --available-channels
              Print a list of all available child channels.

       -a, --add
              You are subscribing system to given channel(s). You have to specify --user and --password.

       -r, --remove
              You are unsubscribing system to given channel(s). You have to specify --user and --password.

       -u, --username
              Your username used to register the system with and for Red Hat Network, RHN Satellite or Spacewalk.  If  you  do  not
              enter this option and it is required, you will be prompted.

       -p, --password
              The  password associated with the username specified with the --username option. This is an unencrypted password.  If
              you do not enter this option and it is required, you will be prompted.

       -c, --channel
              Label of channel you want to subscribe to or unsubscribe from. Can be specified multiple times.

       -v, --verbose
              Print out successfull action.

       -h, --help
              Show a help message and exit.

NOTE
       The addition and removal of channels is mutually exclusive, please use the command twice.

EXAMPLES
       Subscribe to two channels:

              spacewalk-channel --add -c rhn-tools-rhel-i386-server-5 -c rhel-i386-server-vt-5 --user username --password password

       Unsubscribe from channel:

              spacewalk-channel --remove -c rhn-tools-rhel-i386-server-5 -c rhel-i386-server-vt-5 --user username --password password

       List subscribed channels:

              spacewalk-channel --list

SEE ALSO
       rhnplugin(8), rhn_register(8), up2date(5).

AUTHORS
       Miroslav Suchý <msuchy@redhat.com>

BUGS
       Report bugs to <http://bugzilla.redhat.com>.

COPYRIGHT
       Copyright © 2009-2010 Red Hat, Inc.

       This is free software; see the source for copying conditions.  There is NO warranty; not even for MERCHANTABILITY or FITNESS
       FOR A PARTICULAR PURPOSE.

Linux                             2010 July 8             SPACEWALK-CHANNEL(8)

Expected results:

Same results except for "--user" instead of "--username"

Additional info:

rhn-channel --help
Usage: rhn-channel [options]

Options:
  -c CHANNEL, --channel=CHANNEL
                        name of channel you want to (un)subscribe
  -a, --add             subscribe to channel
  -r, --remove          unsubscribe from channel
  -l, --list            list channels
  -L, --available-channels
                        list all available child channels
  -v, --verbose         verbose output
  -u USER, --user=USER  your user name
  -p PASSWORD, --password=PASSWORD
                        your password
  -h, --help            show this help message and exit

Comment 7 Tomas Lestach 2013-08-07 12:48:37 UTC
The bug seems to be fixed in upstream ...

spacewalk.git: 3c927d63fea9717b0299a10921601d01eba5875e

Comment 12 Lukas Pramuk 2013-10-29 11:13:56 UTC
VERIFIED. rhn-setup-1.0.0.1-16.el6.noarch

# man rhn-channel
<snip>
       -u, --user
              Your username used to register the system with and for  Red  Hat  Network,  RHN  Satellite  or
              Spacewalk.  If you do not enter this option and it is required, you will be prompted.

       -p, --password
              The  password  associated with the username specified with the --user option. This is an unen-
              crypted password.  If you do not enter this option and it is required, you will be prompted.
</snip>

>>> no "--username" is present

Comment 13 errata-xmlrpc 2013-11-21 23:15:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1702.html


Note You need to log in before you can comment on or make changes to this bug.