Bug 891755 - Welcome dialog not displayed on Fedora-18-TC4 Live CD
Welcome dialog not displayed on Fedora-18-TC4 Live CD
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedNTH
: i18n, Reopened
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2013-01-03 16:44 EST by Steve Tyler
Modified: 2013-01-09 02:35 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-18.37.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 16:32:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2013-01-03 16:44:25 EST
Description of problem:
When the installer is started on the Fedora-18-TC4 Live CD, the Installation Summary dialog is the first dialog displayed instead of the Welcome dialog. This makes language selection impossible.

NB: The Welcome dialog is displayed as expected on the Fedora-18-TC3 Live CD after updating to anaconda-18.37.8-1.fc18.

Version-Release number of selected component (if applicable):
Fedora-18-TC4-x86_64-Live-Desktop.iso
anaconda-18.37.8-1.fc18

How reproducible:
Always.

Steps to Reproduce:
1. Start Live CD:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Final/TC4/Fedora-18-TC4-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
2. Start installer.
  
Actual results:
The Welcome dialog is not displayed, so no language can be selected.
The installer displays the Installation Summary dialog.

Expected results:
The Welcome dialog is displayed.

Additional info:
Comment 1 Steve Tyler 2013-01-03 17:17:40 EST
Proposing as F18Blocker, because the language cannot be selected.
Comment 2 Chris Lumens 2013-01-03 17:25:51 EST
No, this is not a blocker nor is it a bug.  In the live environment, you should use the environment-provided language selection before running anaconda.  You need to do that anyway to get the live environment displayed in your preferred language.
Comment 3 Steve Tyler 2013-01-03 17:33:28 EST
What "environment-provided language selection"?

The Welcome dialog has been displayed in previous versions[1], so is this a last-minute change in critical functionality?

Anyway, why shouldn't the Welcome dialog be displayed for the friendly "Welcome" that is provides? :-)

[1] See Comment 0:
"Fedora-18-TC3 Live CD after updating to anaconda-18.37.8-1.fc18"
Comment 4 Adam Williamson 2013-01-03 19:44:01 EST
Chris: there is no particularly easy way to change the live language these days - it used to be there in gdm when booting live, it isn't any more. You have to go into GNOME control center, and change the language, and then you have to log out and back in, only there's no way to log out by default on the live image because GNOME doesn't think you have to log out any more, so...it's a whole bunch of fail described in https://bugzilla.redhat.com/show_bug.cgi?id=855697 , basically.

Anyway, all previous 18 builds have shown the Welcome screen in anaconda in live and there was no NTH or blocker bug for 'drop the welcome screen' to justify it changing between TC3 and TC4, so on the face of it, this certainly seems to be a bug.
Comment 5 Adam Williamson 2013-01-03 19:50:30 EST
confirm the bug in TC4. bcl theorizes it's to do with the flip from 'pre-release' to 'release' status in fedora-release (which should stop the display of the 'timbuktu' warning, but not the language screen).
Comment 6 Steve Tyler 2013-01-03 22:07:06 EST
Thanks for reopening, Adam.

When the Live CD is started, a dialog with a huge "Install to Hard Drive" button is displayed on the desktop. After clicking that button, the installer window covers the entire desktop, leaving the user with no clue as to how to select the install language. An experienced Gnome3 user would know to click Activities, click the Show Applications icon, click System Tools, click System Settings, click Region & Language, click the "+" button to add a language, etc.

Not very welcoming, when you actually try it ...
Comment 7 Adam Williamson 2013-01-03 22:32:03 EST
bcl's theory can't be correct, as the betanag switch was not flipped for TC4. betanag switch is not part of fedora-release but a compile-time switch that releng flips when building the images. So that's not it.

"An experienced Gnome3 user would know to click Activities, click the Show Applications icon, click System Tools, click System Settings, click Region & Language, click the "+" button to add a language, etc"

it gets better - per 855697, the 'etc' includes 'force a logout/login somehow'. Or, of course, you can simply open a console and run LC_ALL=es_ES.UTF-8 liveinst, surely everyone knows THAT ;) I think, practically speaking, we need the Welcome dialog back, given the current state of GNOME. Even if it's 'not supposed to be there'.
Comment 8 Kevin Fenzi 2013-01-04 13:21:43 EST
+1 NTH from me.
Comment 9 Tim Flink 2013-01-04 13:52:31 EST
I'm definitely +1 NTH on this and close to +1 blocker if it's really that difficult to change the language used during install from a livecd.
Comment 10 Adam Williamson 2013-01-04 14:14:08 EST
New info: apparently the bug really *is* betanag (for Live, betanag state depends on fedora-release, not the switch releng flips, so in TC4, the Lives are 'final' but the DVD / netinst are 'betanag'), bcl has a fix for it lined up.

I'm +1 blocker and obviously +1 nth on this one, setting AcceptedNTH with the above votes.
Comment 11 Fedora Update System 2013-01-04 19:26:45 EST
anaconda-18.37.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.10-1.fc18
Comment 12 Adam Williamson 2013-01-04 21:30:17 EST
Confirmed the dialog is back with -10 (did a custom live compose).
Comment 13 Steve Tyler 2013-01-04 22:31:21 EST
Likewise verifying that the Welcome dialog is displayed, and language selection is possible from the Live CD:

Information for build anaconda-18.37.10-1.fc18
ID	376453
http://koji.fedoraproject.org/koji/buildinfo?buildID=376453

$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Final/TC4/Fedora-18-TC4-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 14 Fedora Update System 2013-01-07 20:19:28 EST
anaconda-18.37.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.11-1.fc18
Comment 15 Fedora Update System 2013-01-08 16:32:44 EST
anaconda-18.37.11-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.