This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 89176 - procinfo -m fails with more than 32 character devices
procinfo -m fails with more than 32 character devices
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: procinfo (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Jay Turner
:
: 112533 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2003-04-19 04:01 EDT by dellaric
Modified: 2015-01-07 19:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 05:51:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dellaric 2003-04-19 04:01:01 EDT
Description of problem:

procinfo -m gives 'Segmentation fault' when there are more than 32 character
devices in /proc/devices

Version-Release number of selected component (if applicable):

procinfo-18-8

How reproducible:

always, when there are more than 32 character devices in /proc/devices

Steps to Reproduce:

> procinfo -a

or

> procinfo -m
    
Actual results:

Segmantation fault

Expected results:

it should work ...

Additional info:

I suggest to increase the values of MAX_CHRDEV (and maybe MAX_BLKDEV) in
procinfo.h from the current value of 32 to (for example) 64 (or more).
Comment 1 Mike A. Harris 2003-04-19 06:46:15 EDT
Arjan, what are the kernel defined limits for this?
Comment 2 Arjan van de Ven 2003-04-19 06:48:49 EDT
For 2.4 kernels there is a maximum of 256 character major numbers
Comment 3 Mike A. Harris 2004-01-13 11:47:40 EST
*** Bug 112533 has been marked as a duplicate of this bug. ***
Comment 4 Karel Zak 2004-12-17 05:53:00 EST
Fixed for FC-4.

Note You need to log in before you can comment on or make changes to this bug.