Bug 891764 - php-simplepie 1.3.1 breaks wordpress
Summary: php-simplepie 1.3.1 breaks wordpress
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wordpress
Version: 17
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Matěj Cepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-03 22:35 UTC by Scott Shambarger
Modified: 2018-04-11 09:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-26 16:01:58 UTC


Attachments (Terms of Use)

Description Scott Shambarger 2013-01-03 22:35:45 UTC
Description of problem:
php-simplepie 1.3.1 is missing simplepie.inc used by wordpress install

Version-Release number of selected component (if applicable):
php-simplepie-1.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. Install wordpress (any FC17 version)
2. Install php-simplepie-1.3.1-2

Actual results:

Notice broken symlink in /usr/share/wordpress/wp-includes/class-simplepie.php -> /usr/share/php/php-simplepie/simplepie.inc
Wordpress Dashboard unable to load external content.
Errors in apache log.

Expected results:

Symlink should link to file owned by php-simplepie package.
Wordpress Dashboard should load external content.

Additional info:

Updating symlink to point at the SimplePie.php file included in php-simplepie-1.3.1-2 does not work, reports errors such as "Class 'SimplePie_Misc' not found"

Installing php-simplepie-1.2-2 (from FC17 initial release) fixes the problem.

Comment 1 Fedora Update System 2013-01-11 23:47:57 UTC
wordpress-3.5-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wordpress-3.5-3.fc17

Comment 2 Fedora Update System 2013-01-11 23:48:10 UTC
wordpress-3.5-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wordpress-3.5-3.fc16

Comment 3 Fedora Update System 2013-01-11 23:48:22 UTC
wordpress-3.5-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/wordpress-3.5-3.el6

Comment 4 Fedora Update System 2013-01-11 23:48:33 UTC
wordpress-3.5-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/wordpress-3.5-3.fc18

Comment 5 Scott Shambarger 2013-01-12 00:17:51 UTC
Upgraded to php-simplepie-1.3.1-2 and also wordpress-3.5-3, and the Dashboard now correctly loads (and no errors in the logs).

Appears fixed in F17

Comment 6 Scott Shambarger 2013-01-12 00:18:23 UTC
Karma added to F17 release

Comment 7 Fedora Update System 2013-01-12 14:58:58 UTC
Package wordpress-3.5-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wordpress-3.5-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0611/wordpress-3.5-3.fc16
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-01-26 16:02:00 UTC
wordpress-3.5-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-01-26 16:02:57 UTC
wordpress-3.5-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-01-26 16:04:31 UTC
wordpress-3.5-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-01-29 20:04:04 UTC
wordpress-3.5-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.