Bug 89182 - Installer crashes on upgrade from 7.1 - 7.2
Summary: Installer crashes on upgrade from 7.1 - 7.2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-19 13:14 UTC by alan bray
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-12 20:48:30 UTC


Attachments (Terms of Use)

Description alan bray 2003-04-19 13:14:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686; Nav)

Description of problem:
Traceback: (innermost last):
   File "/usr/bin/anaconda", line 620, in ?
     intf.run(id, dispatch, configFileData)
   File "/usr/lib/anaconda/text.py", line 408, in run
         dispatch.gotoNext()
   File "/usr/lib/anaconda/dispatch.py",
  anaconda crashes when attempting to upgrade to RH7.2
     

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade existing system
2.
3.
    

Expected Results:  should have upgraded the installation

Additional info:

the KeyError is ttfm I have no idea what this is.

Comment 1 alan bray 2003-04-20 10:29:56 UTC
Traceback (innermost last):
File "/usr/bin/anaconda", line 620 in ?
     intf.run(id, dispatch, configFileData)
File "/usr/lib/anaconda/text.py", line 408, in run
     dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
     self.moveStep()
File "/usr/lib/anaconda/dispatch.py," line 208, in moveStep
     rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 106, in readPackages
     id.comps = method.readComps(id.hdlist)
File "/usr/lib/anaconda/image.py", line 17, in readComps
     return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
File "/usr/lib/anaconda/comps.py", in __init__
     self.readCompsFile(file, self.packages)
File "/usr/lib/anaconda/comp.py", line 549, in readCompsFile
     list = self.expressions.get(packages[l])
File "/usr/lib/anaconda/comps.py", line 152, in __getitem__
     return self.packages[item]
KeyError: ttfm

Comment 2 Jeremy Katz 2003-04-22 16:12:46 UTC
Is this a modified Red Hat Linux 7.2 in any way?  I don't remember a ttfm
package in Red Hat Linux 7.2.

Comment 3 alan bray 2003-04-23 17:57:10 UTC
From official RedHat 7.2 cdrom-set.
ttfm could be from some 'from source' compiled program. Have been using since 
RH 5.2
I do have 'extras' (not RedHat) such as Coin and Karma but none of them seem to 
have ttfm (is this TrueTypeFontManager?).
Could I upgrade using just RPM? 

Comment 4 Michael Fulbright 2003-05-12 20:48:30 UTC
I would recommend trying a more recent release than 7.2, we've made alot of
improvements since them.


Note You need to log in before you can comment on or make changes to this bug.