Bug 891853 - 'targetcli ls /' without fcoe-target daemon will got miss-leading output "Could not create RTSRoot in configFS."
'targetcli ls /' without fcoe-target daemon will got miss-leading output "Cou...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-target-utils (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Andy Grover
Storage QE
: Regression
Depends On: 951636 980618
Blocks: 961026
  Show dependency treegraph
 
Reported: 2013-01-04 03:22 EST by Gris Ge
Modified: 2013-11-21 17:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
# ^ Known Issue must be selected! Using targetcli to configure the FCoE Target will fail with the message "Could not create RTSRoot in configFS". Ensuring the fcoe-target service is running with "service fcoe-target start" will let targetcli work properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:27:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2013-01-04 03:22:08 EST
Description of problem:
Execute 'targetcli ls /' right after 'yum install -y fcoe-target-utils' will get these miss-leading ouput:
====
[root@storageqe-13 ~]# targetcli ls /
Warning: Could not load preferences file /root/.targetcli/prefs.bin.
Could not create RTSRoot in configFS.
o- / .............................. [...]
  o- backstores ................... [...]
    o- pscsi ......... [0 Storage Object]
====

Version-Release number of selected component (if applicable):
fcoe-target-utils-2.0rc1.fb16-3.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Execute 'targetcli ls /' right after fcoe-target-utils installed (no daemon, no kernel module).
2.
3.
  
Actual results:
Miss leading error message.

Expected results:
Inform user to start 'fcoe-target' daemon first.

Additional info:

In RHEL 6.3 GA (fcoe-target-utils-2.0rc1.fb10-5.el6.noarch), we got correct error message:
===
Warning: Could not load preferences file /root/.targetcli/prefs.bin.
Kernel modules not loaded yet, start the fcoe-target service.
===

Requesting blocker since regression.
Comment 5 RHEL Product and Program Management 2013-07-02 13:50:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 7 Bruno Goncalves 2013-08-14 07:45:48 EDT
Verified with fcoe-target-utils-2.0rc1.fb16-4.el6.noarch.

yum install fcoe-target-utils

rpm -q  fcoe-target-utils
fcoe-target-utils-2.0rc1.fb16-4.el6.noarch

--

targetcli ls /
Warning: Could not load preferences file /root/.targetcli/prefs.bin.
Could not create RTSRoot in configFS.
Kernel modules not loaded yet, start the fcoe-target service.

service fcoe-target start
Starting FCoE Target: 
   Loading modules... done
   Mounting configfs... done
   Applying saved config... done
[  OK  ]


targetcli ls /
o- / ......................................................................................................................... [...]
  o- backstores .............................................................................................................. [...]
  | o- block .................................................................................................... [0 Storage Object]
  | o- fileio ................................................................................................... [0 Storage Object]
  | o- pscsi .................................................................................................... [0 Storage Object]
  o- loopback .......................................................................................................... [0 Targets]
Comment 8 errata-xmlrpc 2013-11-21 17:27:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1683.html

Note You need to log in before you can comment on or make changes to this bug.