Bug 89186 - Installer crashes when searching for prior Linux installations
Summary: Installer crashes when searching for prior Linux installations
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-19 17:22 UTC by Charles Crain
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-20 18:57:59 UTC


Attachments (Terms of Use)
Crash dump for 89186 (42.14 KB, text/plain)
2003-04-22 16:33 UTC, Charles Crain
no flags Details
crash dump from upgrade RH 8 to 9 (47.13 KB, text/plain)
2003-04-30 07:14 UTC, Willi Willig
no flags Details

Description Charles Crain 2003-04-19 17:22:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Upgrading for RH 8.0 to RH 9.0.  Crashe when searching for prior linux
installations. If needed, I have a dump saved to diskette.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.booted from CD
2.Ran CD validation.
3.Answered questions.
4.Installation stated searching for linux installations
    

Actual Results:  bugzilla crash message comes up.

Expected Results:  Anaconda would find RH 8.0 installed on my system.

Additional info:

Comment 1 Michael Fulbright 2003-04-22 16:02:17 UTC
Please attach the crash dump.

Comment 2 Charles Crain 2003-04-22 16:33:22 UTC
Created attachment 91230 [details]
Crash dump for 89186

Comment 3 Willi Willig 2003-04-30 07:14:23 UTC
Created attachment 91408 [details]
crash dump from upgrade RH 8 to 9

Comment 4 Willi Willig 2003-04-30 07:17:19 UTC
I have the same problem with my upgrade from RH Linux (with SGI XFS extension)
8 to 9. The generated crash dump has been attached to this bug.

Comment 5 Michael Fulbright 2003-05-13 16:40:19 UTC
Is the original bug reporter using xfs as well?

We do not support XFS.


Comment 6 Willi Willig 2003-05-14 08:55:29 UTC
I think, that this problem is not related to XFS but anaconda!

Comment 7 Charles Crain 2003-05-16 16:54:53 UTC
To my knowledge, I am not running xfs.  If it is loaded, Red Hat 8 loaded when I
installed it,

Comment 8 Willi Willig 2003-05-20 16:26:43 UTC
For a better understanding -- with XFS I mean the journaling filesystem coming 
from SGI, not the font server. The installation CD with XFS coming from SGI 
(ftp://oss.sgi.com/projects/xfs) is the modified CD #1 from RedHat 
distribution with additional XFS (filesystem) support.

Comment 9 Michael Fulbright 2003-05-20 18:57:59 UTC
We do not support the XFS filesystem.

Comment 10 Willi Willig 2003-05-21 09:23:55 UTC
I don't need support for XFS filesystem, but for anaconda. It denies the 
successfull "normal" upgrade to release 9. Yesteday I could process a upgrade 
due starting the linux kernel with NOPROBE option.


Note You need to log in before you can comment on or make changes to this bug.