Bug 891875 - glest-data update path broken
Summary: glest-data update path broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: megaglest-data
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paulo Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-04 10:31 UTC by Karel Volný
Modified: 2013-01-14 04:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-14 04:05:46 UTC


Attachments (Terms of Use)
sample empty glest.spec (657 bytes, text/plain)
2013-01-07 16:43 UTC, Paulo Andrade
no flags Details
Sample empty glest-data.spec (653 bytes, text/x-rpm-spec)
2013-01-07 16:43 UTC, Paulo Andrade
no flags Details

Description Karel Volný 2013-01-04 10:31:00 UTC
Description of problem:
trying to upgrade, I'm getting broken dependencies

Version-Release number of selected component (if applicable):
megaglest-3.7.1-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. install old F17 (i.e. without updates)
2. yum upgrade --skip-broken
3. yum upgrade
  
Actual results:
--> Running transaction check
---> Package glest.x86_64 0:3.2.2-10.fc17 will be obsoleted
--> Processing Dependency: glest >= 3.2.1 for package: glest-data-3.2.1-5.fc17.noarch
---> Package megaglest.x86_64 0:3.7.1-1.fc17 will be obsoleting
--> Processing Dependency: megaglest-data = 3.7.1 for package: megaglest-3.7.1-1.fc17.x86_64
--> Processing Dependency: p7zip for package: megaglest-3.7.1-1.fc17.x86_64
--> Processing Dependency: libxerces-c.so.27()(64bit) for package: megaglest-3.7.1-1.fc17.x86_64
--> Processing Dependency: libminiupnpc.so.8()(64bit) for package: megaglest-3.7.1-1.fc17.x86_64
--> Processing Dependency: libircclient.so.0()(64bit) for package: megaglest-3.7.1-1.fc17.x86_64
--> Running transaction check
---> Package glest.x86_64 0:3.2.2-10.fc17 will be obsoleted
--> Processing Dependency: glest >= 3.2.1 for package: glest-data-3.2.1-5.fc17.noarch
---> Package libircclient.x86_64 0:1.6-3.fc17 will be installed
---> Package megaglest-data.noarch 0:3.7.1-1.fc17 will be installed
---> Package miniupnpc.x86_64 0:1.6-6.fc17 will be installed
---> Package p7zip.x86_64 0:9.20.1-3.fc17 will be installed
---> Package xerces-c27.x86_64 0:2.7.0-10.fc17 will be installed
--> Finished Dependency Resolution
Error: Package: glest-data-3.2.1-5.fc17.noarch (@fedora)
           Requires: glest >= 3.2.1
           Removing: glest-3.2.2-10.fc17.x86_64 (@fedora)
               glest = 3.2.2-10.fc17
           Obsoleted By: megaglest-3.7.1-1.fc17.x86_64 (updates)
               Not found


Expected results:
no errors

Additional info:
seems that megaglest-data forgot to obsolete glest-data ...?

Comment 1 Paulo Andrade 2013-01-04 12:29:41 UTC
(In reply to comment #0)
> Description of problem:
> trying to upgrade, I'm getting broken dependencies

[...]

> Error: Package: glest-data-3.2.1-5.fc17.noarch (@fedora)
>            Requires: glest >= 3.2.1
>            Removing: glest-3.2.2-10.fc17.x86_64 (@fedora)
>                glest = 3.2.2-10.fc17
>            Obsoleted By: megaglest-3.7.1-1.fc17.x86_64 (updates)
>                Not found
> 
> 
> Expected results:
> no errors
> 
> Additional info:
> seems that megaglest-data forgot to obsolete glest-data ...?

I noticed it also and already commited a fix, see current
last commit in all branches of
http://pkgs.fedoraproject.org/cgit/megaglest-data.git/
but did not yet rebuild as I was waiting for some feedback
on https://bugzilla.redhat.com/show_bug.cgi?id=889685
as that could require a new upstream release (unless those
conditions are specific to my setup) but it may take some
time.

I will submit a megaglest-data update to correct the
upgrade problem.

Comment 2 Fedora Update System 2013-01-04 22:57:49 UTC
megaglest-data-3.7.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/megaglest-data-3.7.1-2.fc16

Comment 3 Fedora Update System 2013-01-04 22:58:28 UTC
megaglest-data-3.7.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/megaglest-data-3.7.1-2.fc17

Comment 4 Fedora Update System 2013-01-04 22:59:10 UTC
megaglest-data-3.7.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/megaglest-data-3.7.1-2.fc18

Comment 5 Paulo Andrade 2013-01-05 00:08:10 UTC
I want to believe it is correct now, and the autoqa
test failed is bogus (because it tests installing *only*
megaglest-data), but that assuming that megaglest
and megaglest-data are installed in the same transaction,
so that megaglest obsoletes glest and megaglest-data
obsoletes glest-data, otherwise, would need to hack a bit
to have megaglest and megaglest-data obsoleting both,
glest and glest-data.

Comment 6 Fedora Update System 2013-01-05 06:52:06 UTC
Package megaglest-data-3.7.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing megaglest-data-3.7.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0248/megaglest-data-3.7.1-2.fc17
then log in and leave karma (feedback).

Comment 7 Karel Volný 2013-01-07 10:56:52 UTC
(In reply to comment #5)
> I want to believe it is correct now, and the autoqa
> test failed is bogus (because it tests installing *only*
> megaglest-data),

yes, it works for me now, thanks

> but that assuming that megaglest
> and megaglest-data are installed in the same transaction,

I guess it is safe to assume that because of the dependencies

Comment 8 Paulo Andrade 2013-01-07 16:43:14 UTC
Created attachment 674161 [details]
sample empty glest.spec

Comment 9 Paulo Andrade 2013-01-07 16:43:49 UTC
Created attachment 674162 [details]
Sample empty glest-data.spec

Comment 10 Paulo Andrade 2013-01-07 16:46:13 UTC
(In reply to comment #7)
> > but that assuming that megaglest
> > and megaglest-data are installed in the same transaction,
> 
> I guess it is safe to assume that because of the dependencies

That is what I expect, otherwise it would be "ugly" to have
megaglest obsoleting glest-data, and megaglest-data obsoleting
glest. I tested building a fake glest and glest-data package
with the attached glest.spec and glest-data.spec, and updates
did work correctly.

Comment 11 Fedora Update System 2013-01-14 04:05:48 UTC
megaglest-data-3.7.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-01-14 04:13:36 UTC
megaglest-data-3.7.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-01-14 04:24:52 UTC
megaglest-data-3.7.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.