This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 891877 - Add Firefox 17 ESR as fully supported browser
Add Firefox 17 ESR as fully supported browser
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Einav Cohen
Pavel Novotny
ux
: ZStream
Depends On:
Blocks: 893020 915537 919981
  Show dependency treegraph
 
Reported: 2013-01-04 05:53 EST by David Jaša
Modified: 2013-08-19 00:01 EDT (History)
13 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Release Note
Doc Text:
Mozilla Firefox 17 is now the only supported browser for accessing the administration and user portals on Red Hat Enterprise Linux clients.
Story Points: ---
Clone Of:
: 893020 919981 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
RHEVM 3.2 User Portal login page in Firefox 17 ESR (106.65 KB, image/png)
2013-02-15 10:27 EST, Pavel Novotny
no flags Details
RHEVM 3.2 Web Admin login page in Firefox 17 ESR (113.58 KB, image/png)
2013-02-15 10:28 EST, Pavel Novotny
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10734 None None None Never

  None (edit)
Description David Jaša 2013-01-04 05:53:44 EST
Description of problem:
Add Firefox 17 ESR as fully supported browser.

Firefox is going to be rebased from 10 ESR to 17 ESR in RHEL soonish so RHEV-M webadmin and UserPortal should be ready for it

Version-Release number of selected component (if applicable):
3.1.0 or .1 / 3.1.0-33.el6ev

How reproducible:
always

Steps to Reproduce:
1. go to https://rhevm.example.org/webadmin with Firefox 17
2.
3.
  
Actual results:
you'll see this message:
This Browser version isn't optimal for displaying the application graphics (refer to Documentation for details)

Expected results:
no such message is displayed

Additional info:
spice XPI plugin works with Firefox 17, no change needed there
Comment 2 Einav Cohen 2013-01-07 12:29:30 EST
patch sent upstream:
http://gerrit.ovirt.org/#/c/10734/
Comment 12 Einav Cohen 2013-01-08 10:33:43 EST
FF17 will be the only supported browser for linux clients in RHEV-M 3.2.

note that we cannot differentiate between ESR vs non-ESR versions: (https://support.mozilla.org/en-US/questions/939929)
so for every FF17 on linux, the "This Browser version isn't optimal" will not be displayed.
Comment 13 Einav Cohen 2013-01-08 11:38:18 EST
(In reply to comment #2)
> patch sent upstream:
> http://gerrit.ovirt.org/#/c/10734/

this patch ^^^ added FF17 as a supported browser.
Patch http://gerrit.ovirt.org/#/c/10773/ removes FF10 as a supported browser.
Comment 14 Einav Cohen 2013-01-08 12:00:30 EST
(In reply to comment #13)

> Patch http://gerrit.ovirt.org/#/c/10773/ removes FF10 as a supported browser.

patch merged upstream:
http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=95bef071a6686d5727a957600cdcda5a7816d97a
Comment 16 Pavel Novotny 2013-02-15 10:26:24 EST
Verified with firefox-17.0.2-3.el6_3 against rhevm-3.2.0-7.el6ev (SF6).

In Firefox 17 ESR, the browser incompatibility message is not shown in the Web Admin and User/Power User Portal. See attached screenshots for details.

As mentioned in comment #13, Firefox 10 is no longer flaged as a supported browser and the browser incompatibility message is displayed there.
Comment 17 Pavel Novotny 2013-02-15 10:27:57 EST
Created attachment 697864 [details]
RHEVM 3.2 User Portal login page in Firefox 17 ESR
Comment 18 Pavel Novotny 2013-02-15 10:28:33 EST
Created attachment 697865 [details]
RHEVM 3.2 Web Admin login page in Firefox 17 ESR
Comment 24 Itamar Heim 2013-06-11 04:21:03 EDT
3.2 has been released
Comment 25 Itamar Heim 2013-06-11 04:24:09 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.