Bug 891881 - F18-TC4 - All QA:TestCase requiring "Automatic Shrink" will fail - Manual Option is Work Around
F18-TC4 - All QA:TestCase requiring "Automatic Shrink" will fail - Manual Opt...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2013-01-04 06:09 EST by Robert Lightfoot
Modified: 2013-01-04 16:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-04 07:07:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Step 1 of Auto Reclaim (37.32 KB, image/png)
2013-01-04 06:09 EST, Robert Lightfoot
no flags Details
Step 2 of Auto Reclaim - Point of Breakage (61.32 KB, image/png)
2013-01-04 06:10 EST, Robert Lightfoot
no flags Details
Step 1 of Manual Shrink (66.03 KB, image/png)
2013-01-04 06:11 EST, Robert Lightfoot
no flags Details
Step 2 of Manual Shrink (40.05 KB, image/png)
2013-01-04 06:12 EST, Robert Lightfoot
no flags Details
Step 3 of Manual Shrink (46.95 KB, image/png)
2013-01-04 06:12 EST, Robert Lightfoot
no flags Details
Step 4 of Manual Shrink - SUCCESS (56.40 KB, image/png)
2013-01-04 06:13 EST, Robert Lightfoot
no flags Details

  None (edit)
Description Robert Lightfoot 2013-01-04 06:09:49 EST
Created attachment 672355 [details]
Step 1 of Auto Reclaim

Description of problem:
Using the Automatic Shrink feature a point is reached where DELETE or CANCEL become the only options.  Manual CHosing of What to shrink and by how much does work.

Version-Release number of selected component (if applicable):


How reproducible:
See Attached Photos for Step by Step

Steps to Reproduce:
1. Boot Installer and install to a disk with an existing OS
2. Attempt to used the Automatic Reclaim SPace / SHrink feature
3. It will not exist and/or work
  
Actual results:


Expected results:
QA:TestCases SHould be compeltable as written

Additional info:
Comment 1 Robert Lightfoot 2013-01-04 06:10:49 EST
Created attachment 672356 [details]
Step 2 of Auto Reclaim - Point of Breakage
Comment 2 Robert Lightfoot 2013-01-04 06:11:23 EST
Created attachment 672358 [details]
Step 1 of Manual Shrink
Comment 3 Robert Lightfoot 2013-01-04 06:12:04 EST
Created attachment 672359 [details]
Step 2 of Manual Shrink
Comment 4 Robert Lightfoot 2013-01-04 06:12:36 EST
Created attachment 672360 [details]
Step 3 of Manual Shrink
Comment 5 Robert Lightfoot 2013-01-04 06:13:12 EST
Created attachment 672361 [details]
Step 4 of Manual Shrink - SUCCESS
Comment 6 Robert Lightfoot 2013-01-04 06:14:55 EST
Proposing as blocker cause it breaks the QA:TestCase Shrink Install and QA;Testcase DUal Boot Windows, but would settle for NTH in this 11th hour as the Manual approach does succeed.  MUST BE DOCUMENTED if graded NTH.
Comment 7 Kamil Páral 2013-01-04 07:07:28 EST
Thanks for bringing this up. The Shrink function was removed from guided partitioning because it caused other bugs (bug 875944 and others).

QA test cases are always lacking behind. In this case, this is not a bug in anaconda (the change was intended), but rather the QA test cases became outdated. I have reported a QA ticket about it:
https://fedorahosted.org/fedora-qa/ticket/327

As a technical note: Even if anaconda doesn't conform to some test cases, it's not automatically a blocker bug. Only if it violates release criteria [1], then it's a blocker bug.
[1] https://fedoraproject.org/wiki/Fedora_Release_Criteria

Closing this report. Thanks.

Note You need to log in before you can comment on or make changes to this bug.