Bug 89194 - updfstab should support fstab options/config directories
updfstab should support fstab options/config directories
Status: CLOSED DUPLICATE of bug 103509
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-04-19 20:27 EDT by Need Real Name
Modified: 2014-03-16 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:52:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-04-19 20:27:07 EDT
Description of problem: 
I am attempting to create appropriate /etc/updfstab.conf.x files for various usb 
storage devices (that are not by default automatically setup).  Some of these 
devices work significantly more stable with the 'sync' option set.  Unfortunately, 
there is no easy way to have this done automatically for a particular device without 
creating a manual fstab entry (hence defeating the purpose of 'updfstab', 'hotplug', 
'devlabel', etc. (which btw, is working out to be a GREAT solution)). 
I would request that an option be added to updfstab in order to add mount options to 
devices.  It would also be nice to able to set a fstype for SOME devices. 
Also, would it be possible to have updfstab support directory entry configs (ala 
/etc/profile.d /etc/xinetd.d etc.).  This way RPMs could be produced to EASILY add 
support for devices not listed. 
For instance, for the Creative Nomad MuVo (MP3 player/usb storage stick), I have 
the following entry (below).  However this device really acts funny in GUI 
filemanagers without the 'sync' option for the mount.  It seems to be significantly 
more stable that way.  I've found other usb sticks that are the same way. 
device muvo { 
    symlink true 
    match hd MUVO 
    partition   1 
Currently, my package(s) add an entry to /etc/updfstab.conf to include the new 
config /etc/updfstab.conf.muvo , etc.... Would be easier to just add a file in a 
directory.  That would prevent me for dealing with uninstall scripts as much (and 
thus keep systems in line) 
Version-Release number of selected component (if applicable): 
current (non-rawhide) 
How reproducible: 
It's an enhancement request. 
This would make it significantly easier to automate ALOT of these usb storage 
devices (particularly the sticks, pens, fabs, mp3 players, etc.).
Comment 1 Bill Nottingham 2004-04-16 00:44:16 EDT

*** This bug has been marked as a duplicate of 103509 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.