Bug 89213 - Blackdown Java JVM crashes
Blackdown Java JVM crashes
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-21 04:34 EDT by darkeye
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description darkeye 2003-04-21 04:34:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
When running the java executable from the Blackdown Java JVM compiled with gcc
3.2, it crashes on exit.

Version-Release number of selected component (if applicable):
glibc-2.3.2-27.9

How reproducible:
Always

Steps to Reproduce:
1. install the Blackdown Java JVM compiled with gcc 3.2
2. type java
3. see the segfault and error report
    

Actual Results:  the output of the java executable is as follows:

$ java
Usage: java [-options] class [args...]
           (to execute a class)
   or  java -jar [-options] jarfile [args...]
           (to execute a jar file)
 
where options include:
    -client       to select the "client" VM
    -server       to select the "server" VM
    -hotspot      is a synonym for the "client" VM  [deprecated]
                  The default VM is client.
 
    -cp -classpath <directories and zip/jar files separated by :>
                  set search path for application classes and resources
    -D<name>=<value>
                  set a system property
    -verbose[:class|gc|jni]
                  enable verbose output
    -version      print product version and exit
    -showversion  print product version and continue
    -? -help      print this help message
    -X            print help on non-standard options
    -ea[:<packagename>...|:<classname>]
    -enableassertions[:<packagename>...|:<classname>]
                  enable assertions
    -da[:<packagename>...|:<classname>]
    -disableassertions[:<packagename>...|:<classname>]
                  disable assertions
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
 
An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : 11 occurred at PC=0x42073770 during VM shutdown
Function=__libc_free+0x70
Library=/lib/tls/libc.so.6
 
Cannot obtain thread information
 
Dynamic libraries:
08048000-0804e000 r-xp 00000000 03:06 3778428    /usr/local/j2sdk1.4.1/bin/java
0804e000-0804f000 rw-p 00005000 03:06 3778428    /usr/local/j2sdk1.4.1/bin/java
40000000-40015000 r-xp 00000000 03:06 3188646    /lib/ld-2.3.2.so
40015000-40016000 rw-p 00014000 03:06 3188646    /lib/ld-2.3.2.so
40017000-40021000 r-xp 00000000 03:06 4301627   
/usr/local/j2sdk1.4.1/jre/lib/i386/native_threads/libhpi.so
40021000-40022000 rw-p 00009000 03:06 4301627   
/usr/local/j2sdk1.4.1/jre/lib/i386/native_threads/libhpi.so
4002c000-40037000 r-xp 00000000 03:06 1013837    /lib/tls/libpthread-0.34.so
40037000-40038000 rw-p 0000a000 03:06 1013837    /lib/tls/libpthread-0.34.so
4003a000-4003d000 r-xp 00000000 03:06 3188659    /lib/libdl-2.3.2.so
4003d000-4003e000 rw-p 00002000 03:06 3188659    /lib/libdl-2.3.2.so
4003f000-4039b000 r-xp 00000000 03:06 2862475   
/usr/local/j2sdk1.4.1/jre/lib/i386/client/libjvm.so
4039b000-403b6000 rw-p 0035b000 03:06 2862475   
/usr/local/j2sdk1.4.1/jre/lib/i386/client/libjvm.so
403c7000-403d9000 r-xp 00000000 03:06 3188663    /lib/libnsl-2.3.2.so
403d9000-403da000 rw-p 00011000 03:06 3188663    /lib/libnsl-2.3.2.so
403dc000-40485000 r-xp 00000000 03:06 359854     /usr/lib/libstdc++.so.5.0.3
40485000-4048a000 rw-p 000a9000 03:06 359854     /usr/lib/libstdc++.so.5.0.3
4048f000-404b0000 r-xp 00000000 03:06 1013835    /lib/tls/libm-2.3.2.so
404b0000-404b1000 rw-p 00020000 03:06 1013835    /lib/tls/libm-2.3.2.so
404b1000-404b8000 r-xp 00000000 03:06 3188703    /lib/libgcc_s-3.2.2-20030225.so.1
404b8000-404b9000 rw-p 00007000 03:06 3188703    /lib/libgcc_s-3.2.2-20030225.so.1
404b9000-404ca000 r-xp 00000000 03:06 4301633   
/usr/local/j2sdk1.4.1/jre/lib/i386/libverify.so
404ca000-404cb000 rw-p 00011000 03:06 4301633   
/usr/local/j2sdk1.4.1/jre/lib/i386/libverify.so
404cb000-404eb000 r-xp 00000000 03:06 4301634   
/usr/local/j2sdk1.4.1/jre/lib/i386/libjava.so
404eb000-404ed000 rw-p 0001f000 03:06 4301634   
/usr/local/j2sdk1.4.1/jre/lib/i386/libjava.so
404ed000-404ff000 r-xp 00000000 03:06 4301636   
/usr/local/j2sdk1.4.1/jre/lib/i386/libzip.so
404ff000-40501000 rw-p 00011000 03:06 4301636   
/usr/local/j2sdk1.4.1/jre/lib/i386/libzip.so
40501000-41bcf000 r--s 00000000 03:06 4301677   
/usr/local/j2sdk1.4.1/jre/lib/rt.jar
41c12000-41c29000 r--s 00000000 03:06 4301657   
/usr/local/j2sdk1.4.1/jre/lib/sunrsasign.jar
41c29000-41c9a000 r--s 00000000 03:06 4301659   
/usr/local/j2sdk1.4.1/jre/lib/jsse.jar
41c9a000-41cad000 r--s 00000000 03:06 4301658   
/usr/local/j2sdk1.4.1/jre/lib/jce.jar
41cad000-41f69000 r--s 00000000 03:06 4301675   
/usr/local/j2sdk1.4.1/jre/lib/charsets.jar
42000000-4212f000 r-xp 00000000 03:06 1013829    /lib/tls/libc-2.3.2.so
4212f000-42132000 rw-p 0012f000 03:06 1013829    /lib/tls/libc-2.3.2.so
4c363000-4c563000 r--p 00000000 03:06 475236     /usr/lib/locale/locale-archive
4c563000-4c56e000 r-xp 00000000 03:06 3188669    /lib/libnss_files-2.3.2.so
4c56e000-4c56f000 rw-p 0000a000 03:06 3188669    /lib/libnss_files-2.3.2.so
 
Local Time = Mon Apr 21 10:23:06 2003
Elapsed Time = 0
#
# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Client VM (Blackdown-1.4.1-01 mixed mode)
#
# An error report file has been saved as hs_err_pid6097.log.
# Please refer to the file for further information.
#
Aborted


Expected Results:  a clean exit after the help information

Additional info:

the same Java JVM worked fine under RedHat 8.0
Comment 1 Michael Lee Yohe 2003-04-21 10:24:40 EDT
This appears to be a duplicate of Bug 89181.  Please read the release notes
included with Red Hat Linux 9 with regards to the new NPTL feature that ships
with the kernel provided with the distribution.  Most JVMs are affected.

Summary: such as long as the application properly implements the POSIX threads
implementation - it should function without a hitch.  However, deviation from
the standard (which can lead to bad things) will lead to bad things on an NPTL
enabled Linux box.
Comment 2 Ulrich Drepper 2003-04-21 19:15:37 EDT
This problem is most probably unrelated to other issues.  I've fixed a problem
in the glibc upstream CVS archive which has been acknowledged to fix a bug
reported in code with this signature.  The next glibc RPM will have this patch.
 I'll eave this bug open until you can test it.  Please confirm it at that point.
Comment 3 Bill Nottingham 2006-08-04 16:12:47 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.