Bug 892138 - kernel-PAE-devel have empty include/linux/version.h -- break builds
kernel-PAE-devel have empty include/linux/version.h -- break builds
Status: CLOSED DUPLICATE of bug 892373
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-05 07:55 EST by Anton Guda
Modified: 2013-01-07 08:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 08:48:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Guda 2013-01-05 07:55:41 EST
Description of problem:
Package kernel-PAE-devel have empty file include/linux/version.h
This breaks build of extra kernel modules, like xtables-addons.
Errors appears like 'undefiled LINUX_VERSION_CODE'

Version-Release number of selected component (if applicable):
3.7.1-2.fc18.i686.PAE (may be not only PAE)

How reproducible:
Always.

Steps to Reproduce:
1. Install new kernel with devel package
2. Try to build xtables-addons
  
Actual results:
Failed with error (see above)


Expected results:
Clean complilation.


Additional info:
If this file is deleted manualy, all works.
Comment 1 Josh Boyer 2013-01-07 08:48:18 EST

*** This bug has been marked as a duplicate of bug 892372 ***
Comment 2 Josh Boyer 2013-01-07 08:49:09 EST

*** This bug has been marked as a duplicate of bug 892373 ***

Note You need to log in before you can comment on or make changes to this bug.