Bug 89214 - winex cannot find symbol h_errno in libc.so.6
Summary: winex cannot find symbol h_errno in libc.so.6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-21 08:40 UTC by darkeye
Modified: 2016-11-24 15:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-21 08:49:53 UTC


Attachments (Terms of Use)

Description darkeye 2003-04-21 08:40:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
when trying to execute something with winex, it complains of not finding a
symbol in glibc.

Version-Release number of selected component (if applicable):
glibc-2.3.2-27.9

How reproducible:
Always

Steps to Reproduce:
1. install WineX 2.2.1-1
2. try to execute a windows executable with winex
3. it will complain that it cannot find symbol h_errno
    

Actual Results:  $ winex /mnt/dvd/Autorun.exe
/usr/lib/transgaming/winex/bin/wine: relocation error:
/usr/lib/transgaming/winex/lib/libwine.so: symbol h_errno, version GLIBC_2.0 not
defined in file libc.so.6 with link time reference


Expected Results:  winex should run fine

Additional info:

I'm using WineX-2.2.1-1, available from transgaming.com

this very version of WineX was working fine under RedHat 8.0

Comment 1 Jakub Jelinek 2003-04-21 08:49:53 UTC
h_errno symbol shouldn't ever appear in shared libraries/binaries since gilbc 2.0
days (aplpications which use h_errno are supposed to #include <netdb.h>, where
h_errno may (and in glibc case is) be defined as a macro.
You can work around this by running the application which has these problems
with LD_ASSUME_KERNEL=2.4.1 in the environment, see release notes.
Alternatively, current CVS wine should work with NPTL just fine too.


Note You need to log in before you can comment on or make changes to this bug.