This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 892212 - javac 100% CPU usage with transparent huges pages defrag enable
javac 100% CPU usage with transparent huges pages defrag enable
Status: CLOSED DUPLICATE of bug 879801
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-05 16:48 EST by Danny Ciarniello
Modified: 2013-01-07 08:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 08:51:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Danny Ciarniello 2013-01-05 16:48:31 EST
Description of problem:
Ever since the 3.5.x kernels, a java build can bring all CPU cores to 100% usage making a system virtually unusable during the build process.

The problem only seems to manifest itself after the system has been running (and used) for some time (a few hours).

Disabling transparent hug page defrag (echo never > /sys/kernel/mm/transparent_hugepage/defrag) fixes the problem.

The problem did not occur with the 3.4.x kernels and since I haven't changed Java versions in some time, it would seem that transparent huge pages are the problem.

Version-Release number of selected component (if applicable):
3.5.x+
3.6.x kernels also have this problem

How reproducible:
Always

Steps to Reproduce:
1. Run a time-consuming maven build on a system that has been up and used for a few hours.
2.
3.
  
Actual results:
All CPU cores go to 100%
System "hangs" until build complete

Expected results:
Random CPU usage
System does not "hang"

Additional info:
I have only really noticed the problem with java builds so it may be that the problem only manifests itself with javac and not java.

The java version where I first noticed this was with Oracle's 1.6.0_30.
Comment 1 Danny Ciarniello 2013-01-05 17:58:56 EST
Please note that I mistakenly stated that the problem started with the 3.5 series of kernels.  It actually started with the 3.6 series.

Dan.
Comment 2 Josh Boyer 2013-01-07 08:51:26 EST

*** This bug has been marked as a duplicate of bug 879801 ***

Note You need to log in before you can comment on or make changes to this bug.