Bug 892270 - Imagemagick supported DDS and MPEG (patent problem)
Summary: Imagemagick supported DDS and MPEG (patent problem)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick   
(Show other bugs)
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2013-01-06 08:50 UTC by mejiko
Modified: 2013-01-11 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 16:31:01 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mejiko 2013-01-06 08:50:58 UTC
Hello.

imagemagick is supported DDS (DirectDraw Surface).
DDS used S3TC compression. S3TC is patened.

http://lists.freedesktop.org/archives/nouveau/2010-March/005439.html
http://lists.debian.org/debian-legal/2010/12/msg00062.html
http://www.google.com/patents?vid=5956431

And imagemagick supported MPEG. (WMV, M2V, M4V, etc. used mpeg2encode)
MPEG is patented.

S3TC and MPEG is "Forbidden items".

https://fedoraproject.org/wiki/Forbidden_items?rd=ForbiddenItems


Suggests:

1. Remove DDS and MPEG module.
2. Replace Patent-free module (e.g: S2TC, Im not tested)
3. Replace imagemagick to graphicmagick (Im not tested) 
4. Remove Fedora repos.

Thanks.



Reference:

https://en.wikipedia.org/wiki/DirectDraw_Surface
https://en.wikipedia.org/wiki/S3_Texture_Compression
https://fedoraproject.org/wiki/Objectives
https://fedoraproject.org/wiki/Software_Patents
https://bugzilla.redhat.com/show_bug.cgi?id=823096

Comment 1 mejiko 2013-01-06 08:51:45 UTC
Blocking FE-Legal, This is patent problem.

Comment 2 mejiko 2013-01-06 08:54:26 UTC
I found typo. (in Description) 

incorrent: DDS used S3TC compression. S3TC is patened.

corrent: DDS used S3TC compression. S3TC is patented.

Sorry.

Comment 3 mejiko 2013-01-06 09:10:05 UTC
Additional Reference URI:

http://www.imagemagick.org/Usage/formats/

Comment 4 Tom "spot" Callaway 2013-01-11 16:31:01 UTC
After review by Red Hat Legal, we determined that because ImageMagick is covered by OIN, we are not aware of any patent issues involving this package. Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.