This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 892278 - [ovirt-engine-dwh] dwh-setup fails.
[ovirt-engine-dwh] dwh-setup fails.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.2.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Yaniv Dary
David Botzer
infra
: Regression, TestBlocker
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-06 04:50 EST by Kiril Nesenko
Modified: 2016-02-10 14:40 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
dwh-setup previously failed because of a syntax error in the upgrade from Red Hat Enterprise Virtualization 3.1 to 3.2 which was not compatible with PostgreSql 8.4. This syntax error has been fixed and upgrading from Red Hat Enterprise Virtualization 3.1 to 3.2 no longer breaks compatibility with PostgreSQL 8.4
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 17:56:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs (10.17 KB, text/x-log)
2013-01-06 04:50 EST, Kiril Nesenko
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10677 None None None Never

  None (edit)
Description Kiril Nesenko 2013-01-06 04:50:45 EST
Created attachment 673304 [details]
logs

Description of problem:

Running  upgrade sql script upgrade/03_02_0030_drop_auto_suspend_column.sql ...

2013-01-06 11:41:11::DEBUG::common_utils::552::root:: stderr = psql:upgrade/03_02_0030_drop_auto_suspend_column.sql:1: ERROR:  syntax error at or near "EXISTS"
LINE 1: ALTER TABLE vm_configuration DROP COLUMN IF EXISTS auto_susp...
                                                    ^

2013-01-06 11:41:11::DEBUG::common_utils::553::root:: retcode = 3
2013-01-06 11:41:11::ERROR::decorators::27::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 20, in wrapped_f
    output = f(*args)
  File "/usr/bin/ovirt-engine-dwh-setup", line 98, in upgradeDB
    output, rc = utils.execCmd(cmdList=cmd, failOnError=True, msg="Error while trying to upgrade %s DB" % DB_NAME)
  File "/usr/share/ovirt-engine-dwh/common_utils.py", line 556, in execCmd
    raise Exception(msg)
Exception: Error while trying to upgrade ovirt_engine_history DB

2013-01-06 11:41:11::ERROR::ovirt-engine-dwh-setup::267::root:: Exception caught!
2013-01-06 11:41:11::ERROR::ovirt-engine-dwh-setup::268::root:: Traceback (most recent call last):
  File "/usr/bin/ovirt-engine-dwh-setup", line 249, in main
    upgradeDB(db_dict)
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 28, in wrapped_f
    raise Exception(instance)
Exception: Error while trying to upgrade ovirt_engine_history DB

Version-Release number of selected component (if applicable):
rhevm-dwh-3.2.0-2.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kiril Nesenko 2013-01-06 04:51:45 EST
Eli seems like its related to the DB, can you take a look please ?
Comment 3 Yaniv Dary 2013-01-06 05:45:52 EST
This was due to syntax in the upgrade not being compatible with 8.4. 
Fixed in patch:
http://gerrit.ovirt.org/#/c/10677
Also re-based to downstream.



Yaniv
Comment 4 Kiril Nesenko 2013-01-06 06:06:39 EST
Works for me with a new build.
Comment 8 David Botzer 2013-02-12 07:58:15 EST
Is it correct to test upgrade SF5 to SF6 ?
and run rhevm-dwh-setup ?
Comment 9 Yaniv Dary 2013-02-13 03:31:09 EST
(In reply to comment #8)
> Is it correct to test upgrade SF5 to SF6 ?
> and run rhevm-dwh-setup ?

Yes
Comment 10 David Botzer 2013-02-13 07:10:48 EST
3.2/SF6 (upgraded from SF5)
DWH works fine, aggreg for samples/hourly
3.2/SF6 (upgraded from SF5)

Waiting for Daily to be verified
Comment 11 David Botzer 2013-02-14 08:39:25 EST
3.2/SF6 (upgraded from SF5)
DWH works fine, aggreg for samples/hourly/daily
3.2/SF6 (upgraded from SF5)
Comment 12 errata-xmlrpc 2013-06-10 17:56:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0926.html

Note You need to log in before you can comment on or make changes to this bug.