Bug 892285 - guestfs-browser crashes when opening a guest filesystem
Summary: guestfs-browser crashes when opening a guest filesystem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: guestfs-browser
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-06 10:16 UTC by Julian Sikorski
Modified: 2013-02-01 16:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-01 16:57:28 UTC


Attachments (Terms of Use)
strace of guestfs-browser -a <image> (423.11 KB, text/plain)
2013-01-25 22:57 UTC, Jacob Hunt
no flags Details

Description Julian Sikorski 2013-01-06 10:16:21 UTC
Description of problem:
guestfs-browser: symbol lookup error: guestfs-browser: undefined symbol: guestfs_safe_malloc

Version-Release number of selected component (if applicable):
guestfs-browser-0.2.1-5.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. sudo guestfs-browser
2. connect to local kvm hypervisor
3. pick a guest from a drop-down list
  
Actual results:
boom

Expected results:
guest filesystem gets opened

Comment 1 Jacob Hunt 2013-01-25 22:56:16 UTC
I have the same issue described by the reporter

guestfs-browser-0.2.1-5.fc18.x86_64

I will attach an strace of the command

-Jacob

Comment 2 Jacob Hunt 2013-01-25 22:57:44 UTC
Created attachment 687740 [details]
strace of guestfs-browser -a <image>

Comment 3 Fedora Update System 2013-01-28 11:50:01 UTC
guestfs-browser-0.2.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/guestfs-browser-0.2.2-1.fc18

Comment 4 Fedora Update System 2013-01-30 00:59:10 UTC
Package guestfs-browser-0.2.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing guestfs-browser-0.2.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1652/guestfs-browser-0.2.2-1.fc18
then log in and leave karma (feedback).

Comment 5 Jacob Hunt 2013-01-30 05:48:51 UTC
Thanks, update works for me.  I left positive karma.

-Jacob

Comment 6 Fedora Update System 2013-02-01 16:57:30 UTC
guestfs-browser-0.2.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.