Bug 892286 - qemu-kvm -device ? get "Parameter 'driver' expects device type" error
qemu-kvm -device ? get "Parameter 'driver' expects device type" error
Status: CLOSED DUPLICATE of bug 669524
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Hai Huang
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-06 05:23 EST by Suqin Huang
Modified: 2013-03-15 08:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 08:27:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2013-01-06 05:23:31 EST
Description of problem:
run qemu-kvm -device ?
"Parameter 'driver' expects device type" error printed instead of device info

Version-Release number of selected component (if applicable):
qemu-kvm-common-1.3.0-2.el7.x86_64
qemu-kvm-tools-1.3.0-2.el7.x86_64
qemu-kvm-kvm-1.3.0-2.el7.x86_64


How reproducible:

100% 
Steps to Reproduce:
1. qemu-kvm -device ?
2.
3.
  
Actual results:
# /usr/libexec/qemu-kvm -drive file=/dev/null -device ?
qemu-kvm: -device 1: Parameter 'driver' expects device typ

Expected results:


Additional info:
Comment 2 Hai Huang 2013-01-08 08:34:26 EST
Command woks on Fedora 17:

[hhuang@dhcp-186-224 ~]$ uname -a
Linux dhcp-186-224.bos.redhat.com 3.3.4-5.fc17.x86_64 #1 SMP Mon May 7 17:29:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[hhuang@dhcp-186-224 ~]$ cat /etc/redhat-release 
Fedora release 17 (Beefy Miracle)
[hhuang@dhcp-186-224 ~]$ qemu-kvm -drive file=/dev/null -device ?
name "ib700", bus ISA
name "testdev", bus ISA
name "sga", bus ISA, desc "Serial Graphics Adapter"
name "qxl", bus PCI, desc "Spice QXL GPU (secondary)"
name "qxl-vga", bus PCI, desc "Spice QXL GPU (primary, vga compatible)"
name "ivshmem", bus PCI
name "pci-assign", bus PCI, desc "pass through host pci devices to the guest"
name "isa-debugcon", bus ISA
name "cirrus-vga", bus PCI, desc "Cirrus CLGD 54xx VGA"
name "virtio-9p-pci", bus PCI
name "usb-wacom-tablet", bus USB, desc "QEMU PenPartner Tablet"
name "usb-braille", bus USB
name "usb-serial", bus USB
name "usb-net", bus USB
name "usb-storage", bus USB
name "usb-host", bus USB
name "usb-hub", bus USB
name "usb-kbd", bus USB
name "usb-mouse", bus USB
name "usb-tablet", bus USB
name "usb-bt-dongle", bus USB
name "smbus-eeprom", bus I2C
name "scsi-generic", bus SCSI, desc "pass through generic scsi device (/dev/sg*)"
name "scsi-disk", bus SCSI, desc "virtual SCSI disk or CD-ROM (legacy)"
name "scsi-block", bus SCSI, desc "SCSI block device passthrough"
name "scsi-cd", bus SCSI, desc "virtual SCSI CD-ROM"
name "scsi-hd", bus SCSI, desc "virtual SCSI disk"
name "x3130-upstream", bus PCI, desc "TI X3130 Upstream Port of PCI Express Switch"
name "xio3130-downstream", bus PCI, desc "TI X3130 Downstream Port of PCI Express Switch"
name "i6300esb", bus PCI
name "vmware-svga", bus PCI
name "virtio-scsi-pci", bus PCI, alias "virtio-scsi"
name "virtio-balloon-pci", bus PCI, alias "virtio-balloon"
name "virtio-serial-pci", bus PCI, alias "virtio-serial"
name "virtio-net-pci", bus PCI, alias "virtio-net"
name "virtio-blk-pci", bus PCI, alias "virtio-blk"
name "virtserialport", bus virtio-serial-bus
name "virtconsole", bus virtio-serial-bus
name "VGA", bus PCI
name "isa-vga", bus ISA
name "ich9-usb-uhci3", bus PCI
name "ich9-usb-uhci2", bus PCI
name "ich9-usb-uhci1", bus PCI
name "vt82c686b-usb-uhci", bus PCI
name "piix4-usb-uhci", bus PCI
name "piix3-usb-uhci", bus PCI
name "usb-redir", bus USB
name "sysbus-ohci", bus System, desc "OHCI USB Controller"
name "pci-ohci", bus PCI, desc "Apple USB Controller"
name "ich9-usb-ehci1", bus PCI
name "usb-ehci", bus PCI
name "usb-ccid", bus USB, desc "CCID Rev 1.1 smartcard reader"
name "isa-serial", bus ISA
name "sb16", bus ISA, desc "Creative Sound Blaster 16"
name "rtl8139", bus PCI
name "pcnet", bus PCI
name "isa-parallel", bus ISA
name "ne2k_pci", bus PCI
name "ne2k_isa", bus ISA
name "lsi53c895a", bus PCI, alias "lsi"
name "ioh3420", bus PCI, desc "Intel IOH device id 3420 PCIE Root Port"
name "intel-hda", bus PCI, desc "Intel HD Audio Controller"
name "ide-drive", bus IDE, desc "virtual IDE disk or CD-ROM (legacy)"
name "ide-cd", bus IDE, desc "virtual IDE CD-ROM"
name "ide-hd", bus IDE, desc "virtual IDE disk"
name "isa-ide", bus ISA
name "ich9-ahci", bus PCI, alias "ahci"
name "hda-duplex", bus HDA, desc "HDA Audio Codec, duplex"
name "hda-output", bus HDA, desc "HDA Audio Codec, output-only"
name "SUNW,fdtwo", bus System
name "sysbus-fdc", bus System
name "ES1370", bus PCI, desc "ENSONIQ AudioPCI ES1370"
name "i82801", bus PCI, desc "Intel i82801 Ethernet"
name "i82562", bus PCI, desc "Intel i82562 Ethernet"
name "i82559er", bus PCI, desc "Intel i82559ER Ethernet"
name "i82559c", bus PCI, desc "Intel i82559C Ethernet"
name "i82559b", bus PCI, desc "Intel i82559B Ethernet"
name "i82559a", bus PCI, desc "Intel i82559A Ethernet"
name "i82558b", bus PCI, desc "Intel i82558B Ethernet"
name "i82558a", bus PCI, desc "Intel i82558A Ethernet"
name "i82557c", bus PCI, desc "Intel i82557C Ethernet"
name "i82557b", bus PCI, desc "Intel i82557B Ethernet"
name "i82557a", bus PCI, desc "Intel i82557A Ethernet"
name "i82551", bus PCI, desc "Intel i82551 Ethernet"
name "i82550", bus PCI, desc "Intel i82550 Ethernet"
name "e1000", bus PCI, desc "Intel Gigabit Ethernet"
name "ccid-card-passthru", bus ccid-bus, desc "passthrough smartcard"
name "ccid-card-emulated", bus ccid-bus, desc "emulated smartcard"
name "isa-applesmc", bus ISA
name "AC97", bus PCI, desc "Intel 82801AA AC97 Audio"
[hhuang@dhcp-186-224 ~]$
Comment 3 Paolo Bonzini 2013-03-15 08:27:29 EDT
This is because you have a file with a single character name in your directory.

For this reason upstream also supports "-device help".

*** This bug has been marked as a duplicate of bug 669524 ***

Note You need to log in before you can comment on or make changes to this bug.