Bug 892287 - Guest sometimes gets call trace or kernel panic when reboot guest then migrate to dst host
Guest sometimes gets call trace or kernel panic when reboot guest then migrat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Dr. David Alan Gilbert
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-06 05:25 EST by Qunfang Zhang
Modified: 2014-06-17 23:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:18:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic log from isa serial (3.95 KB, text/plain)
2013-01-06 05:26 EST, Qunfang Zhang
no flags Details
call trace log from isa serial during migration (22.44 KB, text/plain)
2013-01-06 05:28 EST, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2013-01-06 05:25:34 EST
Description of problem:
Not sure whether this is related to xbzrle migration, But I always hit this problem when xbzrle is enabled. Will try more times and update to this bz. 

Enable xbzrle on both src and dst host and then do migration, guest always gets call trace or kernel panic after migration.

Version-Release number of selected component (if applicable):
kernel-3.6.0-0.29.el7.x86_64
qemu-kvm-1.2.0-21.el7.x86_64

How reproducible:
Sometimes

Steps to Reproduce:
1.Boot a guest on source  host and also destination host with "-incoming tcp:0:5800"

2. Enabled xbzrle on both src and dst host.
(qemu)migrate_set_capabilities xbzrle on

On source host:
(qemu)migrate_set_cache_size 2G

3. Reboot guest and after about 5 seconds implement step 4.

4. Migrate guest to destination host
(qemu) migrate -d tcp:t2:5800
  
Actual results:
Sometimes guest gets call trace or kernel panic during or after migration.
Sometimes just stuck at a point during the boot process and can not continue.

Expected results:
Guest always works fine during and after migraton.

Additional info:
Comment 1 Qunfang Zhang 2013-01-06 05:26:40 EST
Created attachment 673321 [details]
kernel panic log from isa serial
Comment 2 Qunfang Zhang 2013-01-06 05:28:08 EST
Created attachment 673322 [details]
call trace log from isa serial during migration
Comment 4 Orit Wasserman 2013-01-07 03:47:51 EST
What workload is running in the guest?
Can you attach qemu command line ?
Host cpuinfo, memory?
Comment 5 Qunfang Zhang 2013-01-07 03:51:32 EST
(In reply to comment #4)
> What workload is running in the guest?
No application running inside guest, just reboot guest and migrate it.

> Can you attach qemu command line ?
# /usr/libexec/qemu-kvm -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -enable-kvm -name t2-rhel6.4-64 -uuid 61b6c504-5a8b-4fe1-8347-6c929b750dde -k en-us -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0 -drive file=/mnt/rhel6.4-64-virtio.qcow2,if=none,id=disk0,format=qcow2,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x3,drive=disk0,id=disk0  -drive file=/mnt/boot.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,drive=drive-ide0-1-0,bus=ide.1,unit=0,id=cdrom -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=44:37:E6:5E:91:85,bus=pci.0,addr=0x5 -monitor stdio -qmp tcp:0:6666,server,nowait -chardev socket,path=/tmp/isa-serial,server,nowait,id=isa1 -device isa-serial,chardev=isa1,id=isa-serial1 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x8 -chardev socket,id=charchannel0,path=/tmp/serial-socket,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,path=/tmp/foo,server,nowait,id=foo -device virtconsole,chardev=foo,id=console0  -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x9 -vnc :10 -k en-us -boot c -chardev socket,path=/tmp/qga.sock,server,nowait,id=qga0 -device virtserialport,bus=virtio-serial0.0,chardev=qga0,name=org.qemu.guest_agent.0  -global  PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0


> Host cpuinfo, memory?

Host cpuinfo: (4 cpus in total)

processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
stepping	: 7
microcode	: 0x28
cpu MHz		: 1600.000
cache size	: 6144 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 6
initial apicid	: 6
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6184.23
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:


host mem info:
[root@localhost ~]# free -m
             total       used       free     shared    buffers     cached
Mem:          7556       6134       1422          0         34       5072
-/+ buffers/cache:       1026       6529
Swap:         7823         50       7773
Comment 6 Orit Wasserman 2013-12-17 09:00:29 EST
Can you try to reproduce with the latest rhel7 qemu version (1.5.3)?
Comment 7 Qunfang Zhang 2013-12-18 04:32:54 EST
(In reply to Orit Wasserman from comment #6)
> Can you try to reproduce with the latest rhel7 qemu version (1.5.3)?

Re-test the bug on the following version with the same steps in comment 0 and the command line in comment 5. Still can reproduce. Tried about 10 times, reproduced 3 times, guest always stuck on some point although the migration completes. 

qemu-kvm-1.5.3-24.el7.x86_64
kernel-3.10.0-63.el7.x86_64
Comment 8 Orit Wasserman 2014-01-02 03:25:02 EST
Does it happen without XBZRLE?
Comment 9 Qunfang Zhang 2014-01-06 04:14:32 EST
(In reply to Orit Wasserman from comment #8)
> Does it happen without XBZRLE?

I just retest again on the following version with same steps in comment 0:

(1) with xbzrle: tried about 12 times, reproduced twice.
(2) without xbzrle: tried about 12 times. can NOT reproduce.

Host version:
kernel-3.10.0-65.el7.x86_64
qemu-kvm-1.5.3-31.el7.x86_64
Comment 14 Ludek Smid 2014-06-13 07:18:08 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.