Bug 892300 - 'glance control all start' does not work
'glance control all start' does not work
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: RHOS Maint
Yaniv Kaul
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-06 07:57 EST by Yaniv Kaul
Modified: 2013-07-03 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 04:38:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2013-01-06 07:57:53 EST
Description of problem:
- 'glance control all start' does not seem to start the registry service.
[root@ykaul-os-glance glance]# ps -ef |grep glance
root      4853  2790  0 14:54 pts/0    00:00:00 grep glance
[root@ykaul-os-glance glance]# glance-control all start
Starting glance-api
Starting glance-registry with /var/run/glance/all.pid
Starting glance-scrubber with /var/run/glance/all.pid
[root@ykaul-os-glance glance]# ps -ef |grep glance
root      4860     1  4 14:55 ?        00:00:00 /usr/bin/python /usr/bin/glance-api
root      4895  4860 15 14:55 ?        00:00:00 /usr/bin/python /usr/bin/glance-api
root      4896  4860 15 14:55 ?        00:00:00 /usr/bin/python /usr/bin/glance-api
root      4898  2790  0 14:55 pts/0    00:00:00 grep glance


(note the use of /var/run/glance/all.pid file?!)

Version-Release number of selected component (if applicable):
openstack-glance-2012.2.1-1.el6ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Eoghan Glynn 2013-01-10 11:20:06 EST
I've reproduced the issue and it should be fixed, but direct use of glance-control would not be the recommended way of starting the glance services in RHOS, i.e. users would generally be directed to use something like:

  for svc in api registry ; do service openstack-glance-$svc start ; done
Comment 3 Flavio Percoco 2013-02-15 04:38:06 EST
This has been fixed upstream but, since the recommended usage is not to use glance-control but starting each service individually, it doesn't make sense to backport this fix.

Note You need to log in before you can comment on or make changes to this bug.