Bug 892351 - vncviewer ssh tunneling broken (-via option)
vncviewer ssh tunneling broken (-via option)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
18
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-06 15:16 EST by Aleksandar Kostadinov
Modified: 2013-04-30 19:53 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-19 09:17:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Kostadinov 2013-01-06 15:16:56 EST
tigervnc-1.2.80-0.6.20121126svn5015.fc18.x86_64

-via option does not seem available invoking vncviewer. It's a very important option for working conveniently and securely with vnc. I am finding a bug [1] in the tigervnc project.
IMHO if there is not enough manpower for the project to provide a sane linux client, then why not make tightvnc at least as a viewer in Fedora?

[1] http://sourceforge.net/tracker/index.php?func=detail&aid=3588877&group_id=254363&atid=1126848
Comment 1 Chris Tyler 2013-01-16 17:52:16 EST
I'm seeing the same thing, and note the man page still lists the -via option as being available. This is a regression from F17.
Comment 2 Adam Tkac 2013-01-23 09:01:47 EST
I just commited r5032 to upstream which re-adds the -via support. Update for Fedora will be available soon.
Comment 3 Aleksandar Kostadinov 2013-01-23 11:19:14 EST
Thank you very much!
Comment 4 Fedora Update System 2013-01-24 08:36:15 EST
tigervnc-1.2.80-0.8.20130124svn5036.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tigervnc-1.2.80-0.8.20130124svn5036.fc18
Comment 5 Aleksandar Kostadinov 2013-01-24 09:30:24 EST
Couldn't wait and grabbed it from the link above. Works awesome!
Comment 6 Fedora Update System 2013-01-25 16:31:14 EST
Package tigervnc-1.2.80-0.8.20130124svn5036.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tigervnc-1.2.80-0.8.20130124svn5036.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1479/tigervnc-1.2.80-0.8.20130124svn5036.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-01-28 10:12:40 EST
tigervnc-1.2.80-0.8.20130124svn5036.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Kevin Fenzi 2013-02-18 17:59:13 EST
Could we pretty please have this in rawhide too? You seem to have just updated f18 without updating rawhide. ;(
Comment 9 Adam Tkac 2013-02-19 07:41:10 EST
(In reply to comment #8)
> Could we pretty please have this in rawhide too? You seem to have just
> updated f18 without updating rawhide. ;(

Rawhide has been updated as well but build of tigervnc package failed due to updated X.Org server packages and porting tigervnc to new X.Org is not trivial...
Comment 10 Adam Tkac 2013-02-19 09:17:12 EST
Fixed also in tigervnc-1.2.80-0.10.20130219svn5047.fc19
Comment 11 Kevin Fenzi 2013-02-19 09:41:51 EST
(In reply to comment #9)
>
> Rawhide has been updated as well but build of tigervnc package failed due to
> updated X.Org server packages and porting tigervnc to new X.Org is not
> trivial...

Ah, ok. I think I looked at the rawhide failed build back when it was done, but then forgot about it and wondered where the version with -via was. Thanks for the info.

Note You need to log in before you can comment on or make changes to this bug.