Bug 892377 - munin 2.0.8+ has a broken package ownership that prevents uninstall
Summary: munin 2.0.8+ has a broken package ownership that prevents uninstall
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: munin
Version: el6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 892380 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-07 00:34 UTC by Trent Hornibrook
Modified: 2013-01-29 20:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-20 03:03:44 UTC


Attachments (Terms of Use)

Description Trent Hornibrook 2013-01-07 00:34:13 UTC
Description of problem:


Version-Release number of selected component (if applicable):
CentOS release 6.3 (Final)


munin-node-2.0.8-1.el6.noarch
munin-common-2.0.8-1.el6.noarch

How reproducible:


Install 
munin-common-2.0.8-1.el6.noarch
and
munin-node-2.0.8-1.el6.noarch

on a new centos 6 (rhel6) box.



Attempt to uninstall munin-node & munin-common.




Steps to Reproduce:
root@testing3.awsnginx tmp # rpm -e munin-node munin-common
error reading information on service munin-asyncd: No such file or directory
error reading information on service munin-fcgi-html: No such file or directory
error reading information on service munin-fcgi-graph: No such file or directory
error: %preun(munin-node-2.0.8-1.el6.noarch) scriptlet failed, exit status 1


  
Actual results:


as above

Expected results:

That the package would uninstall.

Additional info:


Package 2.0.6-2 works fine.
Package 2.0.9 (that is in epel-test is also affected.

Comment 1 Kevin Fenzi 2013-01-07 01:46:08 UTC
*** Bug 892380 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2013-01-09 19:38:09 UTC
munin-2.0.10-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.el5

Comment 3 Fedora Update System 2013-01-09 19:39:16 UTC
munin-2.0.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.el6

Comment 4 Fedora Update System 2013-01-09 19:40:19 UTC
munin-2.0.10-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.fc16

Comment 5 Fedora Update System 2013-01-09 19:42:31 UTC
munin-2.0.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.fc17

Comment 6 Fedora Update System 2013-01-09 19:43:41 UTC
munin-2.0.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/munin-2.0.10-1.fc18

Comment 7 Fedora Update System 2013-01-10 21:31:18 UTC
Package munin-2.0.10-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing munin-2.0.10-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0593/munin-2.0.10-1.fc18
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-01-20 03:03:45 UTC
munin-2.0.10-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-01-22 03:40:14 UTC
munin-2.0.10-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-01-23 01:45:38 UTC
munin-2.0.10-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-01-23 01:48:40 UTC
munin-2.0.10-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-01-29 20:04:45 UTC
munin-2.0.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.