Bug 892382 - [PATCH] js miscompiled on armv5
[PATCH] js miscompiled on armv5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: js (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker F18ArmBlocker
  Show dependency treegraph
 
Reported: 2013-01-06 19:37 EST by Lubomir Rintel
Modified: 2013-03-16 04:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 12:19:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
[PATCH] Fix compiler flags on ARM (4.89 KB, application/octet-stream)
2013-01-06 19:37 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2013-01-06 19:37:02 EST
Created attachment 673567 [details]
[PATCH] Fix compiler flags on ARM

Description of problem:

js build hardcodes -march=armv7-a, which is wrong on non-v7 ARms.

Version-Release number of selected component (if applicable):

js-1.8.5-11.fc19.armv5tel

How reproducible:

On a v5 arm:
[lkundrak@megalodon ~]$ lscpu
Architecture:          armv5tel
Byte Order:            Little Endian
CPU(s):                1
On-line CPU(s) list:   0
Thread(s) per core:    1
Core(s) per socket:    1
Socket(s):             1
[lkundrak@megalodon ~]$ uname -a
Linux megalodon 3.7.0-6.fc19.armv5tel.kirkwood #1 Mon Dec 24 10:36:18 EST 2012 armv5tel armv5tel armv5tel GNU/Linux
[lkundrak@megalodon ~]$

Steps to Reproduce:
1. Run js
  
Actual results:

[root@megalodon lkundrak]# /usr/lib/polkit-1/polkitd
Successfully changed to user polkitd
Illegal instruction
[root@megalodon lkundrak]# exit
[lkundrak@megalodon ~]$ js
Illegal instruction
[lkundrak@megalodon ~]$ 

Expected results:

[root@megalodon lkundrak]# /usr/lib/polkit-1/polkitd
Successfully changed to user polkitd
00:31:53.348: Loading rules from directory /etc/polkit-1/rules.d
00:31:53.352: Loading rules from directory /usr/share/polkit-1/rules.d
^C
[root@megalodon lkundrak]# exit
[lkundrak@megalodon ~]$ js
js> trolol
typein:1: ReferenceError: trolol is not defined
js> 

Additional info:

Fix for the issue is attached.
Comment 1 Peter Robinson 2013-01-07 04:06:50 EST
Actually we shouldn't have " -mthumb $MOZ_ARM_VFP_FLAGS" either as they're set by the rpm cflags to our required settings as well. I'll push a modified version of the patch today.
Comment 2 Dennis Gilmore 2013-01-23 09:39:12 EST
I had already applied basicaly the same thing,  Peter is is correct, the build does not use -mthumb  that part of the files is chosen when you enable thumb optimisations as a build flag
Comment 3 Fedora Update System 2013-01-23 13:42:24 EST
js-1.8.5-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/js-1.8.5-12.fc18
Comment 4 Fedora Update System 2013-01-24 17:40:58 EST
Package js-1.8.5-12.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing js-1.8.5-12.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1446/js-1.8.5-12.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-02-01 12:19:18 EST
js-1.8.5-12.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Pavel Alexeev 2013-03-16 04:17:53 EDT
Thank you, guys.

Note You need to log in before you can comment on or make changes to this bug.