Bug 892465 - "expected downtime" in the output of "info migrate" is always 0
"expected downtime" in the output of "info migrate" is always 0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 03:40 EST by Qunfang Zhang
Modified: 2013-12-18 10:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 10:03:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2013-01-07 03:40:56 EST
Description of problem:
We have "expected downtime" item in the output of "info migrate"(human monitor) or "query-migrate" (qmp) commands. That is a very good feature for user to know that how long the downtime has to be to finish migration. But currently the "expected downtime" is always 0, that does not provide the expected downtime information.

Version-Release number of selected component (if applicable):
qemu-kvm-1.3.0-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot a guest on src host and also dst host with listening mode.

2. Implement migration.

3. (qemu) info migrate
or {"execute":"query-migrate"}

  
Actual results:
(qemu) info migrate
capabilities: xbzrle: off 
Migration status: active
total time: 4081 milliseconds
expected downtime: 0 milliseconds
transferred ram: 127790 kbytes
remaining ram: 444488 kbytes
total ram: 2105728 kbytes
duplicate: 383457 pages
normal: 31854 pages
normal bytes: 127416 kbytes

Expected results:
"expected downtime" should provide the correct time.

Additional info:
Comment 2 Qunfang Zhang 2013-01-07 05:14:32 EST
Hi, Juan
The "expected downtime" will be 0 at the beginning, and when the 'remaining ram' is small, the "expected downtime begins to change.  Is this expected?  Could you help confirm and close it if not a bug.
Comment 3 Juan Quintela 2013-02-20 04:18:26 EST
it is 0 at the start.  But there were a bug upstream (and in RHEL7).  Patches are posted upstream to fix this.  We are thinking about getting the "initial" downtime value as the one set with migration_max_downtime (much better value than zero).

Note You need to log in before you can comment on or make changes to this bug.