This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 89249 - size-512 in /proc/slabinfo keeps growing and machine dies after 10 day
size-512 in /proc/slabinfo keeps growing and machine dies after 10 day
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-21 17:55 EDT by Francois Romieu
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 17:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
slab-512 output samples for 25 minutes (16.26 KB, text/plain)
2003-04-21 18:03 EDT, Francois Romieu
no flags Details
/proc/slabinfo (3.40 KB, text/plain)
2003-04-21 18:04 EDT, Francois Romieu
no flags Details
/proc/meminfo (601 bytes, text/plain)
2003-04-21 18:05 EDT, Francois Romieu
no flags Details
ps auwx output (8.43 KB, text/plain)
2003-04-21 18:06 EDT, Francois Romieu
no flags Details
lsmod output (954 bytes, text/plain)
2003-04-21 18:07 EDT, Francois Romieu
no flags Details
/proc/cpuinfo (318 bytes, text/plain)
2003-04-21 18:08 EDT, Francois Romieu
no flags Details
/sbin/ifconfig output (1.12 KB, text/plain)
2003-04-21 18:09 EDT, Francois Romieu
no flags Details
Shaping script (3.28 KB, text/plain)
2003-04-21 18:17 EDT, Francois Romieu
no flags Details

  None (edit)
Description Francois Romieu 2003-04-21 17:55:35 EDT
Description of problem:  
  
Machine serves http/dns/smtp. After 10 days, services stop responding while  
ping is still ok. fork/vfork error appear in the logs. Machine ends  
unusable. apache is configured to regularly restart and no process shows 
significant memory usage. 
  
Version-Release number of selected component (if applicable):  
  
2.4.18-27.7.x  
  
How reproducible:  
  
The machine should stop within 2/3 days for the third time.  
  
Steps to Reproduce:  
1.  
2.  
3.  
      
Actual results:  
  
  
Expected results:  
  
  
Additional info:
Comment 1 Arjan van de Ven 2003-04-21 18:01:35 EDT
so something is leaking memory; and since you're the first report of this I have
to assume it's something uncommon in your configuration; could you post lsmod
output and maybe describe things that could be uncommon in your setup ?
Comment 2 Francois Romieu 2003-04-21 18:03:01 EDT
Created attachment 91214 [details]
slab-512 output samples for 25 minutes
Comment 3 Francois Romieu 2003-04-21 18:04:02 EDT
Created attachment 91215 [details]
/proc/slabinfo
Comment 4 Francois Romieu 2003-04-21 18:05:01 EDT
Created attachment 91216 [details]
/proc/meminfo
Comment 5 Francois Romieu 2003-04-21 18:06:31 EDT
Created attachment 91217 [details]
ps auwx output
Comment 6 Francois Romieu 2003-04-21 18:07:32 EDT
Created attachment 91218 [details]
lsmod output
Comment 7 Francois Romieu 2003-04-21 18:08:25 EDT
Created attachment 91219 [details]
/proc/cpuinfo
Comment 8 Francois Romieu 2003-04-21 18:09:34 EDT
Created attachment 91220 [details]
/sbin/ifconfig output
Comment 9 Arjan van de Ven 2003-04-21 18:12:26 EDT
sch_sfq                 4288   6 (autoclean)
cls_u32                 5444   1 (autoclean)
sch_cbq                13248   1 (autoclean)

are 3 modules that are "uncommon" a bit; are you actively using them?
Comment 10 Francois Romieu 2003-04-21 18:16:28 EDT
The machine is limiting bandwidth at ~1.8Mbps. Setup script sent as attachment.  
Comment 11 Francois Romieu 2003-04-21 18:17:26 EDT
Created attachment 91221 [details]
Shaping script
Comment 12 Francois Romieu 2003-04-21 18:27:59 EDT
> sch_sfq                 4288   6 (autoclean) 
> cls_u32                 5444   1 (autoclean) 
> sch_cbq                13248   1 (autoclean) 
> 
> are 3 modules that are "uncommon" a bit; are you actively using them? 
 
Yes, see http://pulsar.zoreil.com/rrdtool/eth0-weekly.gif. 
 
Previous setup (2.4.18-3) didn't show these symptoms but I can't claim that 
the bandwidth was limited in the exact same way. 

Note You need to log in before you can comment on or make changes to this bug.