Bug 892494 - deleting existing LV doesn't free space to allow creation of new LV
deleting existing LV doesn't free space to allow creation of new LV
Status: CLOSED DUPLICATE of bug 892269
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2013-01-07 04:32 EST by Kamil Páral
Modified: 2013-01-07 11:23 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 11:23:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug demonstration video (829.80 KB, video/ogg)
2013-01-07 04:32 EST, Kamil Páral
no flags Details
anaconda.log (36.31 KB, text/plain)
2013-01-07 04:34 EST, Kamil Páral
no flags Details
program.log (33.04 KB, text/plain)
2013-01-07 04:34 EST, Kamil Páral
no flags Details
storage.log (97.84 KB, text/plain)
2013-01-07 04:34 EST, Kamil Páral
no flags Details
syslog (63.08 KB, text/plain)
2013-01-07 04:34 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-01-07 04:32:21 EST
Created attachment 673844 [details]
bug demonstration video

Description of problem:
If I deleting an existing LV in the manual part window, I can't create a new LV, because anaconda thinks there is no free space.

See video.

Version-Release number of selected component (if applicable):
anaconda 18.37.10

How reproducible:
always

Steps to Reproduce:
1. have a VG with no free space
2. go to manual partitioning
3. delete some existing LV
4. try to create a new LV, it has cca 1 MB of maximum size 
  
Actual results:
anaconda doesn't count deleted LVs as a free space in VG

Expected results:
deleted LVs are considered a free space
Comment 1 Kamil Páral 2013-01-07 04:34:26 EST
Created attachment 673845 [details]
anaconda.log
Comment 2 Kamil Páral 2013-01-07 04:34:31 EST
Created attachment 673846 [details]
program.log
Comment 3 Kamil Páral 2013-01-07 04:34:34 EST
Created attachment 673847 [details]
storage.log
Comment 4 Kamil Páral 2013-01-07 04:34:38 EST
Created attachment 673848 [details]
syslog
Comment 5 Kamil Páral 2013-01-07 04:35:26 EST
Proposing as Blocker.
Comment 6 Kamil Páral 2013-01-07 07:49:21 EST
This is very similar to bug 892269 - that one concerns shrinking existing LVs, this one concerns deleting existing LVs.
Comment 7 Adam Williamson 2013-01-07 11:04:21 EST
I think it's probably a dupe. If you create a new LV with a specified size, does that 'work' as detailed in 892269?
Comment 8 Adam Williamson 2013-01-07 11:23:00 EST
Confirmed, the behaviour is exactly the same, I just tested it.

*** This bug has been marked as a duplicate of bug 892269 ***

Note You need to log in before you can comment on or make changes to this bug.