Bug 892621 - Anaconda FC18-TC4 does not present BIOS RAID as available storage
Anaconda FC18-TC4 does not present BIOS RAID as available storage
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2013-01-07 07:28 EST by Jes Sorensen
Modified: 2013-01-08 16:32 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 16:31:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log files from /tmp, including /proc/mdstat output (640.00 KB, application/x-tar)
2013-01-07 07:31 EST, Jes Sorensen
no flags Details

  None (edit)
Description Jes Sorensen 2013-01-07 07:28:28 EST
Description of problem:
With the update to TC4, Anaconda does not present BIOS RAID storage.

Version-Release number of selected component (if applicable):
Whatever is on Fedora-18-TC4-x86_64-netinst.iso

How reproducible:
Every time

Steps to Reproduce:
Been running tests on Fedora 17, was going to reinstall Fedora 18 to test
the same bug there. Pulled the TC4 image, but got nowhere :(

See attached tarball of logfiles - note I included the output of /proc/mdstat
which shows that the array is in fact assembled correctly.

This is a major regression!
Comment 1 Jes Sorensen 2013-01-07 07:31:02 EST
Created attachment 673983 [details]
log files from /tmp, including /proc/mdstat output
Comment 2 Jes Sorensen 2013-01-07 07:45:19 EST
Just to confirm this worked in the previous release, I ran the same test
with the TC3 image and it behaves as expected.
Comment 3 Jes Sorensen 2013-01-07 08:29:54 EST
Tested RC1 - it is equally broken
Comment 4 Jaroslav Reznik 2013-01-07 08:39:20 EST
Proposing as blocker: The installer must be able to create and install to software, hardware or BIOS RAID-0, RAID-1 or RAID-5 partitions for anything except /boot 

Based on comment #2, it looks like a regression between TC3 and TC4.
Comment 5 David Lehman 2013-01-07 12:03:51 EST
I have a possible fix. To test it, add the following to your boot command line:

 updates=http://dlehman.fedorapeople.org/updates/updates-892621.0.img
Comment 6 Adam Williamson 2013-01-07 13:33:31 EST
Discussed at 2013-01-07 QA meeting acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2013-01-07/fedora-qa.2013-01-07-16.01.log.txt . Accepted as a blocker per criterion cited in comment #4.
Comment 7 Jes Sorensen 2013-01-07 15:46:48 EST
Tested the update fix from comment #5. With that the BIOS RAID device shows
up under available storage.

I didn't continue with the install as I have data on the system I need for
testing right now, but I presume it will work.

Jes
Comment 8 Adam Williamson 2013-01-07 16:40:28 EST
Bug and fix confirmed on my system: without the updates.img I don't see my array available for install at all, with the updates.img it is available and I can successfully complete and boot an RC1 install. Please go ahead and apply for the next anaconda build.
Comment 9 Fedora Update System 2013-01-07 20:18:57 EST
anaconda-18.37.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.11-1.fc18
Comment 10 Fedora Update System 2013-01-08 16:32:01 EST
anaconda-18.37.11-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.