Bug 892638 - [3.1.z] engine: rerun of HA vm fails when vm's pid is killed during live snapshot
[3.1.z] engine: rerun of HA vm fails when vm's pid is killed during live snap...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.2
x86_64 Linux
high Severity high
: ---
: 3.1.5
Assigned To: Arik
meital avital
virt
: ZStream
Depends On: 878041
Blocks: 891634
  Show dependency treegraph
 
Reported: 2013-01-07 08:42 EST by Idith Tal-Kohen
Modified: 2014-09-28 02:38 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, if a highly available virtual machine was killed during a live snapshot, the virtual machine would not be able to be re-run because the virtual machine would be in a different state than was expected by the engine. Now, the status of the virtual machine is saved when live snapshot is initiated and is referenced so that a virtual machine can be re-run after it has been killed during a live snapshot.
Story Points: ---
Clone Of: 878041
Environment:
Last Closed: 2013-06-18 05:34:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10618 None None None Never

  None (edit)
Comment 5 Aharon Canan 2013-06-10 10:38:57 EDT
Verified using 3.1.5 (si29)

verification steps:
1. Create snapshot while VM is up
2. while snapshot kill the VM process on the relevant host (kill -9 the qemu-kvm process)
3. check that snapshot created and that VM is up again


environment:
VM server with HA
2 hosts
2 storage domain (ISCSI)
1 DC
Comment 6 Aharon Canan 2013-06-10 10:45:07 EDT
just to make things clearer, 

In this bug I verified the live snapshot and not the live storage migration
for the live storage migration we have different bug.
Comment 8 errata-xmlrpc 2013-06-18 05:34:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0950.html

Note You need to log in before you can comment on or make changes to this bug.