Bug 892657 - options not listed in --help and manpage
Summary: options not listed in --help and manpage
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: createrepo (Show other bugs)
(Show other bugs)
Version: 6.5
Hardware: Unspecified Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: Karel Srot
URL:
Whiteboard:
Keywords: ManPageChange
: 879018 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-07 14:14 UTC by Karel Srot
Modified: 2018-12-03 18:06 UTC (History)
2 users (show)

Fixed In Version: createrepo-0.9.9-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: Documentation not upto date (and one copy and paste error). Consequence: Some options were not listed in the man page. Fix: Added options to man page Result: Options documented.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 07:44:33 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0879 normal SHIPPED_LIVE createrepo bug fix update 2013-05-30 11:43:34 UTC

Description Karel Srot 2013-01-07 14:14:13 UTC
Description of problem:

4 option(s) reported by the program ONLY:
	--basedir
	--retain-old-md
	--update-md-path
	--xz
1 option(s) reported by the man page ONLY:
	-V


Version-Release number of selected component (if applicable):
createrepo-0.9.9-17.el6.noarch

Comment 1 James Antill 2013-04-16 19:56:38 UTC
--xz is the compat. option for --compress-type, and is now hidden.

-V never existed (probably a copy and paste problem from another man page).

Man page only fix:

commit f280fa5848e1b6b77fb16a2b694e0b4167c20fe6
Author: James Antill <james@and.org>
Date:   Tue Apr 16 15:55:59 2013 -0400

    Fix options documentation. BZ 892657.

Comment 4 Zdeněk Pavlas 2013-05-14 13:19:23 UTC
*** Bug 879018 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2013-05-30 07:44:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0879.html


Note You need to log in before you can comment on or make changes to this bug.