Bug 892665 - slow NIC or wifi -> installation source: nothing selected
slow NIC or wifi -> installation source: nothing selected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
RejectedBlocker https://fedoraproject...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-07 09:44 EST by Kamil Páral
Modified: 2013-05-10 21:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 21:54:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unplugged.png (35.36 KB, image/png)
2013-01-07 09:44 EST, Kamil Páral
no flags Details
connecting.png (36.16 KB, image/png)
2013-01-07 09:44 EST, Kamil Páral
no flags Details
connected.png (44.68 KB, image/png)
2013-01-07 09:45 EST, Kamil Páral
no flags Details
nothing-selected.png (51.81 KB, image/png)
2013-01-07 09:45 EST, Kamil Páral
no flags Details
installation-source.png (25.42 KB, image/png)
2013-01-07 09:45 EST, Kamil Páral
no flags Details
anaconda.log (6.69 KB, text/plain)
2013-01-07 09:45 EST, Kamil Páral
no flags Details
ifcfg.log (568 bytes, text/plain)
2013-01-07 09:46 EST, Kamil Páral
no flags Details
packaging.log (2.64 KB, text/plain)
2013-01-07 09:46 EST, Kamil Páral
no flags Details
program.log (35.26 KB, text/plain)
2013-01-07 09:47 EST, Kamil Páral
no flags Details
syslog (106.20 KB, text/plain)
2013-01-07 09:47 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-01-07 09:44:06 EST
Description of problem:
I have a machine with a really slow NIC (integrated on Asus motherboard, a brand new and modern board). It takes a long time before it gets link address (10-20 seconds?). But there are also other reasons for slow NICs, like USB NIC dongles (see bug 832510).

If I boot anaconda netinst on this machine, I receive "cable unplugged" screen (see unplugged.png). If I wait, in some time it changes to connecting.png and finally connected.png. If I wait the whole time and hit Continue only afterwards, everything is fine and awesome.

But if I hit Continue in the "cable unplugged" state, the main hub says "Nothing selected" in the Installation source (see nothing-selected.png). It's orange and blocks installation. Even when Network configuration spoke changes from "Connecting..." to "Connected", it still says "Nothing selected", it is not reloaded.

If I click inside Installation source, the dialog looks normal (see installation-source.png) and it says "Closest Mirror". But hitting Done doesn't not reload the information, the main hub still says "Nothing selected", and I can't continue installation.

Workaround: In the Installation source provide an invalid http repo -> Done -> switch back to Closest Mirror -> Done.

Version-Release number of selected component (if applicable):
anaconda 18.37.10
F18 RC1

How reproducible:
always

Steps to Reproduce:
1. you need to have a machine with slow NIC. I don't know how to simulate that
2. boot netinst and hit Continue before you get a link address
  
Expected results:
1) anaconda automatically refreshes Installation source when network is finally up
2) if I visit the spoke manually and hit Done, the information is reloaded if it was previously in an error state

Additional information:
Attaching logs of the "Nothing selected" state.
Comment 1 Kamil Páral 2013-01-07 09:44:56 EST
Created attachment 674092 [details]
unplugged.png
Comment 2 Kamil Páral 2013-01-07 09:44:59 EST
Created attachment 674093 [details]
connecting.png
Comment 3 Kamil Páral 2013-01-07 09:45:03 EST
Created attachment 674094 [details]
connected.png
Comment 4 Kamil Páral 2013-01-07 09:45:09 EST
Created attachment 674095 [details]
nothing-selected.png
Comment 5 Kamil Páral 2013-01-07 09:45:13 EST
Created attachment 674096 [details]
installation-source.png
Comment 6 Kamil Páral 2013-01-07 09:45:58 EST
Created attachment 674097 [details]
anaconda.log
Comment 7 Kamil Páral 2013-01-07 09:46:01 EST
Created attachment 674098 [details]
ifcfg.log
Comment 8 Kamil Páral 2013-01-07 09:46:14 EST
Created attachment 674099 [details]
packaging.log
Comment 9 Kamil Páral 2013-01-07 09:47:28 EST
Created attachment 674100 [details]
program.log
Comment 10 Kamil Páral 2013-01-07 09:47:32 EST
Created attachment 674101 [details]
syslog
Comment 11 Kamil Páral 2013-01-08 03:31:55 EST
I see the same problem when using wifi (and no wired connection):
1. boot netinst
2. in the initial screen, select a wifi network
3. it is not clear that you should click Configure, so don't click it now, click Continue
4. the main hub says Installation Source - Nothing selected, and Network configuration - disconnected
5. Enter Network Configuration, select wifi network again, this time click Configure, enter wifi password, OK, see that you are connected now
6. go back to main hub, Installation source still says "Nothing selected" and it can't be fixed by entering the screen and confirming "Closest Mirror"

A more clever approach, still broken:
1. boot netinst
2. in the initial screen, select a wifi network. Because you are clever now, hit Configure immediately, provide wifi password, see that you are connected, hit Continue
3. the main hub says Network configuration - connected to FOO network, but it still claims Installation Source - Nothing selected

Net result - people with just wifi will have a hard time to install from the network. It takes a non-trivial workaround to fix the "Installation source - Nothing selected" issue.

This probably also affects DVD+updates installation (updates won't be downloaded). Of course, it doesn't affect Live installation.

Proposing for Blocker/NTH discussion.
Comment 12 Radek Vykydal 2013-01-08 08:16:26 EST
(In reply to comment #11)

> 3. it is not clear that you should click Configure, so don't click it now,
> click Continue

Yes, this will be fixed post F18 with our secret agent asking for passwords. For F18, there is a note in Installation guide.

> 
> A more clever approach, still broken:
> 1. boot netinst
> 2. in the initial screen, select a wifi network. Because you are clever now,
> hit Configure immediately, provide wifi password, see that you are
> connected, hit Continue
> 3. the main hub says Network configuration - connected to FOO network, but
> it still claims Installation Source - Nothing selected
> 
> Net result - people with just wifi will have a hard time to install from the
> network. It takes a non-trivial workaround to fix the "Installation source -
> Nothing selected" issue.

Patch sent to anaconda-patches. Visiting Source spoke and just hitting Done (Closest mirror being pre-selected) would do the right thing now.
I think this is reasonable fix in scope of this bug.

Automatic re-download of source metadata on network status change would need some more careful thinking, we have a separate bug for it.
Comment 13 Jaroslav Reznik 2013-01-08 08:28:59 EST
Kamil, what's that "a non-trivial workaround"?
Comment 14 Radek Vykydal 2013-01-08 08:42:06 EST
(In reply to comment #13)
> Kamil, what's that "a non-trivial workaround"?

I believe it is what is described here:
https://bugzilla.redhat.com/show_bug.cgi?id=873468#c0

"If you hit the bug, it's annoying to work around: you have to go into Installation Source and change it somehow - just changing it to 'http://foo' is enough - and hit Done, wait for the hub to process, then go back into Installation Source and change back to 'Closest mirror' and hit Done again. At that point, things work normally."
Comment 15 Kamil Páral 2013-01-08 08:59:01 EST
(In reply to comment #13)
> Kamil, what's that "a non-trivial workaround"?

grep -i workaround #description ;-)

> "If you hit the bug, it's annoying to work around: you have to go into
> Installation Source and change it somehow - just changing it to 'http://foo'
> is enough - and hit Done, wait for the hub to process, then go back into
> Installation Source and change back to 'Closest mirror' and hit Done again.
> At that point, things work normally."

Exactly.
Comment 16 Radek Vykydal 2013-01-08 09:02:02 EST
Updates image with fix:
http://rvykydal.fedorapeople.org/updates.nothingselected.img
Comment 17 Jaroslav Reznik 2013-01-08 09:03:46 EST
(In reply to comment #15)
> (In reply to comment #13)
> > Kamil, what's that "a non-trivial workaround"?
> 
> grep -i workaround #description ;-)

Sorry, I'm blind but also thanks for Radek's more detailed one :)

(In reply to comment #12)

> Patch sent to anaconda-patches. Visiting Source spoke and just hitting Done
> (Closest mirror being pre-selected) would do the right thing now.
> I think this is reasonable fix in scope of this bug.

So the fix is still some kind of workaround, just not as complicated - it still has to be manually set, right?
Comment 18 Radek Vykydal 2013-01-08 09:17:04 EST
This fix is b) from bug #870570 (the Description).
The a) is what I am talking about in comment #12:
	
(In reply to comment #12)
> Automatic re-download of source metadata on network status change would need
> some more careful thinking, we have a separate bug for it.
Comment 19 Kamil Páral 2013-01-08 09:26:49 EST
(In reply to comment #16)
> Updates image with fix:
> http://rvykydal.fedorapeople.org/updates.nothingselected.img

I copied that locally and served as inst.updates=hd:sdb1:/updates.img. Works great. You have to enter the Installation Source screen, but simple OK reloads the metadata, no hacks needed. Also if you're on a wifi and wait for your connection before entering the main hub, the metadata are downloaded with no intervention needed.
Comment 20 Adam Williamson 2013-01-08 12:42:30 EST
I think this bug may be just on the wrong side of jlaska's law of diminishing blocker returns. There are various workarounds, and it's a pretty uncommon case, and at some point we have to stop poking anaconda...but that's just my first reaction.
Comment 21 Jaroslav Reznik 2013-01-08 14:34:59 EST
As we see "pretty safe" NTHs coming back, I'm inclined to -1/-1 either at this time.
Comment 22 Tim Flink 2013-01-08 14:43:45 EST
I'm also -1/-1. We need to release some time and this seems like a bit of a corner case and not too terrible to workaround
Comment 23 Adam Williamson 2013-01-08 16:39:25 EST
Dan408 is also -1, so that's -4 / +0 at present. Setting rejectedblocker. If anyone strongly disagrees, please speak up!
Comment 24 Adam Williamson 2013-05-10 21:54:58 EDT
The fix for this went into git master:

commit 86a264cec88a2cccbcb0faf631748811ac53e5f1
Author: Radek Vykydal <rvykydal@redhat.com>
Date:   Tue Jan 8 14:02:30 2013 +0100

    Don't redownload payload from closest mirror only if we actually have some (#892665)
    
    Follow-up of commit fc0ed882a0507794685d4eaad28ddbe78dad9e6

Kamil tested it and gave it the thumbs up in c#19. So let's close this.

Note You need to log in before you can comment on or make changes to this bug.