Bug 892703 - Bridge member is pointing to wrong bridge with biosdevname devices
Summary: Bridge member is pointing to wrong bridge with biosdevname devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Dave Young
QA Contact: Guangze Bai
URL:
Whiteboard:
Depends On:
Blocks: 886782 894951 902691
TreeView+ depends on / blocked
 
Reported: 2013-01-07 16:16 UTC by Fabian Deutsch
Modified: 2015-02-08 21:38 UTC (History)
9 users (show)

Fixed In Version: kexec-tools-2.0.0-258.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 894951 (view as bug list)
Environment:
Last Closed: 2013-02-21 07:49:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch v5 (2.76 KB, patch)
2013-01-18 02:20 UTC, Dave Young
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0281 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2013-02-20 20:37:00 UTC

Description Fabian Deutsch 2013-01-07 16:16:42 UTC
Description of problem:
A bisodevname named NIC em1 (which is a member of brem1) get's correctly mapped to eth0 (so the rename/mapping succeeds), additionally the BRIDGE key in the ifcfg is adjusted to point to breth1.
But the bridge brem1 is not mapped to breth0, but keeps it's name brem1. This breaks the bridge configuration in the kdump kernel, as the nic is now a slave of the not existing bridge.
I don't know why the BRIDGE entry in the NICs ifcfg was changed.

There was a bug also related to bridges not to long ago bug #821930 but this seems to be different ans it's related to the ifnames in the cfg files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See bug #886782

Comment 18 Dave Young 2013-01-18 02:20:59 UTC
Created attachment 681968 [details]
patch v5

Comment 22 errata-xmlrpc 2013-02-21 07:49:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0281.html


Note You need to log in before you can comment on or make changes to this bug.