Bug 89287 - USB memory stick doesn't work
Summary: USB memory stick doesn't work
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-22 08:39 UTC by Łukasz Sznuk
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-27 21:18:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Łukasz Sznuk 2003-04-22 08:39:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
After plugging in the USB memory stick, it doesn't work at all. I also cannot
read the contents of /proc/bus/usb/devices for some time (few seconds), and
later it doesn't show the memory stick. Some error messages, which are
reproduced below, are displayed or stored in a log file.

Kernel modules loaded include usb-storage and sd_mod. Attempt to remove sd_mod
results in a segmentation fault.


Version-Release number of selected component (if applicable):
kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. Turn on the machine, wait for it to boot.
2. Plug in memory stick.
3. Watch the results.
    

Actual Results:  Error messages, problems with /proc/bus/usb/...

Expected Results:  Memory stick ready to be mounted as /dev/sda1.

Additional info:

Some of error messages:
Apr 21 23:44:58 dhcp03 kernel: usb-uhci.c: interrupt, status 2, frame# 117
Apr 21 23:44:59 dhcp03 kernel: usb_control/bulk_msg: timeout
[...]
Apr 21 23:45:25 dhcp03 kernel: scsi: device set offline - not ready or command
[...]
Apr 21 23:46:08 dhcp03 kernel: resize_dma_pool: unknown device type -1

Machine I use is an old, 440LX chipset-based Pentium II, which uses usb-uhci driver.

Memory stick works OK with Redhat 7.3, and with Redhat 9 using a 2.4.18-3 kernel
(from RH 7.3).

Comment 1 Pete Zaitcev 2003-06-03 20:15:58 UTC
Please try the 2.4.20-18 errata. Apparently, upstread destroyed usb-uhci.
If that fails, we'd need a step-by-step resolution, but I hope not.


Comment 2 Łukasz Sznuk 2003-06-27 21:18:57 UTC
After installing 2.4.20-18 everything seems to be fine.



Note You need to log in before you can comment on or make changes to this bug.