Bug 892924 - unclear licensed files
unclear licensed files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-01-08 04:10 EST by mejiko
Modified: 2013-01-15 10:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-15 10:40:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mejiko 2013-01-08 04:10:38 EST
Hello.

mesa included unclear licensed files.


Source RPM is : mesa-8.0.4-1.fc17.src.rpm

Files:

Mesa-8.0.4/src/gallium/auxiliary/postprocess/pp_mlaa*

This source code license is BSD like license, but this license section 2 is unclear and questionable.

Its non-free.

Note: I am not a lawer


Source URI:

https://daemonfc.wordpress.com/2011/10/09/mesa3d-and-the-art-of-slipping-proprietary-software-through-the-back-door/

http://phoronix.com/forums/showthread.php?56844-MLAA-For-Mesa-Is-Ready-For-Testing/page6

Question: Is this license is compatible GPL and acceptable fedora ? 


Seggests:

1. Remove unclear files and rebuild.
2. Replace Fedora-free files.
3. Remove Fedora repos.

Thanks.


Reference:

https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing
Comment 1 mejiko 2013-01-08 04:11:35 EST
Blocking FE-Legal, This is license problem (unclear).
Comment 2 Tom "spot" Callaway 2013-01-15 10:40:17 EST
I emailed the copyright holder for that code and clarified his intent for the license. Basically, what he was trying to say is that the additional clause in part 2 of the license is an optional way to meet the BSD requirement, but you can ignore it and treat that code as pure BSD. It is not intended as a use restriction. Red Hat Legal agrees, and asked me to include a copy of the clarifying email correspondence in the mesa package, which I have done as of mesa-9.0.1-4.fc19. Fedora will treat that code as BSD.

Note You need to log in before you can comment on or make changes to this bug.