Bug 892925 - mesa-domos included non-free files.
Summary: mesa-domos included non-free files.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa-demos   
(Show other bugs)
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2013-01-08 09:15 UTC by mejiko
Modified: 2013-01-20 03:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-20 03:15:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mejiko 2013-01-08 09:15:29 UTC
Hello.

mesa-demos included non-free files.


Source RPM is : mesa-demos-7.10-6.20101028.fc17.src.rpm 


Files:

mesa-demos-20101028/src/demos/pointblast.c
mesa-demos-20101028/src/demos/spriteblast.c

This license is redistributable, but not allow modify.

because "Allowing modify" statement (example: "You may freely modify or distribute modify version..." etc) is not find.

Its non-free.

And, This files is not "firmware" or "contents". This is "code".



Segs:

1. Remove non-free code and rebuild.
2. Replace to Fedora-free files.
3. Remove Fedora repos.


Thanks.


Reference:

http://libreplanet.org/wiki/List_of_software_that_does_not_respect_the_Free_System_Distribution_Guidelines#mesademos
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Binary_Firmware
https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#CodeVsContent

Comment 1 mejiko 2013-01-08 09:16:15 UTC
Blocking FE-Legal, This is license problem.

Comment 2 mejiko 2013-01-08 09:24:45 UTC
I found typo. (in Description) 

incorrent: segs:

corrent: suggests:

Sorry.

Comment 3 Fedora Update System 2013-01-08 17:17:53 UTC
mesa-demos-8.0.1-1.20121218git6eef979.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mesa-demos-8.0.1-1.20121218git6eef979.fc18

Comment 4 Fedora Update System 2013-01-09 22:51:14 UTC
Package mesa-demos-8.0.1-1.20121218git6eef979.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-demos-8.0.1-1.20121218git6eef979.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0514/mesa-demos-8.0.1-1.20121218git6eef979.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-01-20 03:15:22 UTC
mesa-demos-8.0.1-1.20121218git6eef979.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.