Bug 892929 - NetworkManager cannot establish connection via bluez
NetworkManager cannot establish connection via bluez
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 905917 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 04:41 EST by Jiri Eischmann
Modified: 2013-02-05 12:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 12:03:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 885818 None None None Never

  None (edit)
Description Jiri Eischmann 2013-01-08 04:41:49 EST
Description of problem:
Connecting to the Internet via Bluetooth doesn't work in F18 because NetworkManager fails to setup connection via bluez. 

Version-Release number of selected component (if applicable):
Fedora 18 (up-to-date)
NetworkManager 0.9.7.0
bluez 4.101

How reproducible:


Steps to Reproduce:
1. The cell phone is paired using the GUI preferences in GNOME 3.6.
2. The device (cell phone) is marked to use as network device (PAN/NAP)
3. Clicking the device item in the "Broadband connections" submenu in the NetworkManager applet (GNOME).
  
Actual results:
Notification that says NM failed to setup the connection pops up.
This is what messages log says:
Jan  8 04:15:18 dhcp-29-228 NetworkManager[2129]: <warn> Error connecting with bluez: Method "Connect" with signature "s" on interface "org.bluez.Network" doesn't exist
Jan  8 04:15:18 dhcp-29-228 NetworkManager[2129]: <info> (00:1D:FE:7F:EA:74): device state change: config -> failed (reason 'bluetooth-failed') [50 120 44]
Jan  8 04:15:18 dhcp-29-228 NetworkManager[2129]: <warn> Activation (00:1D:FE:7F:EA:74) failed for connection 'Jiri Eischmann's HP Pre3 Network'
Jan  8 04:15:18 dhcp-29-228 NetworkManager[2129]: <info> (00:1D:FE:7F:EA:74): device state change: failed -> disconnected (reason 'none') [120 30 0]
Jan  8 04:15:18 dhcp-29-228 NetworkManager[2129]: <info> (00:1D:FE:7F:EA:74): deactivating device (reason 'none') [0]

Expected results:
NM properly establishes the connection via bluez like in Fedora 17.
Comment 1 Dan Williams 2013-01-08 12:07:25 EST
Seems to be a change in Bluez 4.101; rebuilding bluez-4.101 for F17 gives me the same result.
Comment 2 Dan Williams 2013-01-08 12:48:44 EST
This is a bluez bug.  Soemtime between 4.99 and 4.101, the org.bluez.Network.Connect method signature was changed from:

	{ "Connect",		"s",	"s",	connection_connect,
						G_DBUS_METHOD_FLAG_ASYNC },

to:

	{ GDBUS_ASYNC_METHOD("Connect",
			NULL, NULL, connection_connect) },

note the two "NULL" arguments there; that indicates that the D-Bus API no longer expects arguments for connection_connect(), but that function call clearly expects them.  Thus, bluez (perhaps unintentionally) broke D-Bus API.
Comment 3 Dan Williams 2013-01-08 12:56:11 EST
See https://launchpad.net/ubuntu/quantal/+source/bluez/4.101-0ubuntu4/+files/bluez_4.101-0ubuntu4.debian.tar.gz which already has the suggested patch for above.
Comment 4 Dan Williams 2013-01-08 12:57:49 EST
(In reply to comment #3)
> See
> https://launchpad.net/ubuntu/quantal/+source/bluez/4.101-0ubuntu4/+files/
> bluez_4.101-0ubuntu4.debian.tar.gz which already has the suggested patch for
> above.

The git-XXXX ones are relevant for this specific issue.
Comment 5 Fedora Update System 2013-01-10 06:02:19 EST
bluez-4.101-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluez-4.101-6.fc18
Comment 6 Fedora Update System 2013-01-10 16:27:05 EST
Package bluez-4.101-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluez-4.101-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0559/bluez-4.101-6.fc18
then log in and leave karma (feedback).
Comment 7 Dan Williams 2013-02-04 13:25:28 EST
*** Bug 905917 has been marked as a duplicate of this bug. ***
Comment 8 David Woodhouse 2013-02-04 16:38:54 EST
Yay, with bluez-4.101-6 I can connect. Still can't *disconnect* though...
Comment 9 Fedora Update System 2013-02-05 12:03:48 EST
bluez-4.101-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.