Bug 89293 - Segfault with nfs mount
Summary: Segfault with nfs mount
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-22 11:24 UTC by Ted Kaczmarek
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-27 21:05:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ted Kaczmarek 2003-04-22 11:24:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Description of problem:
If I have an nfs mount on my RH9 box, rpm will segafault. After unmounting the
nfs dir it no longer segfaults.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download wine-20030408-1rh8winehq.i686.rpm fom sourceforge
2. Try to do an rpm -Uvh on it
3.
    

Actual Results:  Segfault

Expected Results:  Installs

Additional info:

Only happens when nfs mount is mounted, unmounting it rpm sorta works.
Still hangs, kill -9, rm __db* then try again it works.

Comment 1 Jeff Johnson 2003-04-22 13:41:04 UTC
FWIW, I run rpm with NFS mounts all the time.

Does the segfault reappear when you remount the NFS volume?

WHat's different abou that particular mount point?


Comment 2 Ted Kaczmarek 2003-04-22 14:03:16 UTC
I found some babdlocks on a swap partition, I will have create a new swap and
try this again.



Comment 3 Jeff Johnson 2003-04-23 15:27:36 UTC
Was the segfault from the bad swap?

Comment 4 Ted Kaczmarek 2003-04-24 10:56:02 UTC
Don't think so, need to eliminate that possibility. I can't establish a behavior
pattern that is consistent. Figthing with Dell to get anew drive :-(.

Comment 5 Jeff Johnson 2003-04-24 18:55:48 UTC
OK, still waiting to see if problem is reproducible.

Comment 6 Ted Kaczmarek 2003-11-30 04:58:40 UTC
Jeff, I have been unable to reproduce across nfs or samba mounts for
quite a while, close it out. If it happens again I will get some media
data to go along with the problem.

Thanks,
Ted


Note You need to log in before you can comment on or make changes to this bug.