Bug 892974 - VirtualBox kernel modules bulding fails for VirtualBox-4.2-4.2.6_82870_fedora18-1.x86_64 together with kernel-3.7.1-2.fc18.x86_64
VirtualBox kernel modules bulding fails for VirtualBox-4.2-4.2.6_82870_fedora...
Status: CLOSED DUPLICATE of bug 892373
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 05:51 EST by Joachim Backes
Modified: 2013-01-08 08:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 08:50:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-01-08 05:51:57 EST
Description of problem:

I'm running VirtualBox-4.2-4.2.6_82870_fedora18-1.x86_64 in Fedora18
together with kernel-3.6.11-3.fc18.x86_64 without problems.

But after I updated to kernel-3.7.1-2.fc18.x86_64, the vbox modules fail to build:

==================================================================
Building process
==================================================================

Stopping VirtualBox kernel modules                         [  OK  ]
Uninstalling old Virtukernel-devel-3.7.1-2.fc18.x86_64alBox DKMS kernel modules            [  OK  ]
Trying to register the VirtualBox kernel modules using DKMSError! Bad
return status for module build on kernel: 3.7.1-2.fc18.x86_64 (x86_64)
Consult /var/lib/dkms/vboxhost/4.2.6/build/make.log for more information.
                                                           [FAILED]
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules                      [FAILED]
  (Look at /var/log/vbox-install.log to find out what went wrong)

==================================================================
/var/log/vbox-install.log
==================================================================

Uninstalling modules from DKMS
  removing old DKMS module vboxhost version  4.2.6

------------------------------
Deleting module version: 4.2.6
completely from the DKMS tree.
------------------------------
Done.
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxhost/4.2.6/source ->
                 /usr/src/vboxhost-4.2.6

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.7.1-2.fc18.x86_64 -C
/lib/modules/3.7.1-2.fc18.x86_64/build
M=/var/lib/dkms/vboxhost/4.2.6/build....(bad exit status: 2)
Failed to install using DKMS, attempting to install without
make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0
CONFIG_MODULE_SIG= -C /lib/modules/3.7.1-2.fc18.x86_64/build modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (	\
echo >&2;							\
echo >&2 "  ERROR: Kernel configuration is invalid.";		\
echo >&2 "         include/generated/autoconf.h or
include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src
to fix it.";	\
echo >&2 ;							\
/bin/false)
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f scripts/Makefile.build obj=/tmp/vbox.0
  gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d  -nostdinc -isystem
/usr/lib/gcc/x86_64-redhat-linux/4.7.2/include
-I/usr/src/kernels/3.7.1-2.fc18.x86_64/arch/x86/include
-Iarch/x86/include/generated  -Iinclude
-I/usr/src/kernels/3.7.1-2.fc18.x86_64/arch/x86/include/uapi
-Iarch/x86/include/generated/uapi
-I/usr/src/kernels/3.7.1-2.fc18.x86_64/include/uapi
-Iinclude/generated/uapi -include
/usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/kconfig.h
-D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs
-fno-strict-aliasing -fno-common -Werror-implicit-function-declaration
-Wno-format-security -fno-delete-null-pointer-checks -O2 -m64
-mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time
-maccumulate-outgoing-args -fstack-protector -DCONFIG_AS_CFI=1
-DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1
-DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_AVX=1 -pipe -Wno-sign-compare
-fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow
-mno-avx -Wframe-larger-than=2048 -Wno-unused-but-set-variable
-fno-omit-frame-pointer -fno-optimize-sibling-calls -g -pg -mfentry
-DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign
-fno-strict-overflow -fconserve-stack -DCC_HAVE_ASM_GOTO -include
/tmp/vbox.0/include/VBox/SUPDrvMangling.h
-I/lib/modules/3.7.1-2.fc18.x86_64/build/include -I/tmp/vbox.0/
-I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/
-I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux
-D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0
-DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC
-DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE
-D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)"
-D"KBUILD_MODNAME=KBUILD_STR(vkernel-devel-3.7.1-2.fc18.x86_64boxdrv)" -c -o
/tmp/vbox.0/linux/SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
In file included from /tmp/vbox.0/include/VBox/types.h:30:0,
                 from /tmp/vbox.0/linux/../SUPDrvInternal.h:35,
                 from /tmp/vbox.0/linux/SUPDrv-linux.c:31:
/tmp/vbox.0/include/iprt/types.h:108:7: warning: "LINUX_VERSION_CODE"
is not defined [-Wundef]
/tmp/vbox.0/include/iprt/types.h:108:29: warning: "KERNEL_VERSION" is
not defined [-Wundef]
/tmp/vbox.0/include/iprt/types.h:108:43: error: missing binary
operator before token "("
/tmp/vbox.0/include/iprt/types.h:112:32: fatal error:
linux/autoconf.h: No such file or directory
compilation terminated.
make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
make[1]: *** [_module_/tmp/vbox.0] Error 2


Version-Release number of selected component (if applicable):
kernel-3.7.1-2.fc18.x86_64
kernel-devel-3.7.1-2.fc18.x86_64
How reproducible:

alwyas

Steps to Reproduce:
1.Install VirtualBox-4.2-4.2.6_82870_fedora18-1.x86_64 from virtualbox.org
2./etc/init.d/vboxdrv setup
3.
  
Actual results:
see description

Expected results:
building vbox modules does not fail

Additional info:

I don't know if it's a kernel or kernel-devel issue.
Comment 1 Joachim Backes 2013-01-08 07:21:17 EST
Following

https://www.virtualbox.org/ticket/11036#comment:14

(remove the empty file /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h)

will solve my build problem too! No more any flaw during
/etc/init.d/vboxdrv setup
Comment 2 Josh Boyer 2013-01-08 08:50:53 EST

*** This bug has been marked as a duplicate of bug 892373 ***

Note You need to log in before you can comment on or make changes to this bug.