Bug 893039 - 3.7.1-2.fc18.x86_64: broken /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h
3.7.1-2.fc18.x86_64: broken /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linu...
Status: CLOSED DUPLICATE of bug 892373
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 08:58 EST by Harald Reindl
Modified: 2013-01-08 09:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 09:20:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-01-08 08:58:49 EST
besides that it would be nice to have at least at koji a official 3.7.1 kernel the F18 package has a broken /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h

this is in fact a zero-byte-file which leads to have delete it for the needed symlink to get VMware Workstation running with 3.7.x

http://slackblogs.blogspot.co.at/2012/11/vmware-workstation-901-and-linux-kernel_18.html
________________________________________________


[root@srv-rhsoft:/downloads]$ ln -s /usr/src/kernels/3.7.1-2.fc18.x86_64/include/generated/uapi/linux/version.h /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h
ln: Symbolischen Verknüpfung "/usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h" konnte angelgt werden: Die Datei existiert bereits

[root@srv-rhsoft:/downloads]$ stat /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h
  Datei: "/usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h"
  Größe: 0              Blöcke: 0          EA Block: 4096   reguläre leere Datei
Gerät: 901h/2305d       Inode: 1706187     Verknüpfungen: 1
Zugriff: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Zugriff    : 2013-01-04 01:17:29.000000000 +0100
Modifiziert: 2013-01-04 01:17:29.000000000 +0100
Geändert   : 2013-01-08 06:39:22.739701596 +0100
 Geburt    : -

[root@srv-rhsoft:/downloads]$ unlink /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h

[root@srv-rhsoft:/downloads]$ ln -s /usr/src/kernels/3.7.1-2.fc18.x86_64/include/generated/uapi/linux/version.h /usr/src/kernels/3.7.1-2.fc18.x86_64/include/linux/version.h
Comment 1 Josh Boyer 2013-01-08 09:20:17 EST

*** This bug has been marked as a duplicate of bug 892373 ***

Note You need to log in before you can comment on or make changes to this bug.